USB keyboard - setup clarification

In the setup of a USB keyboard it states that usbcore.authorized_default=0 should be set for 4.1 users, to I believe restrict USB access to keyboards only(?)

It’s not clear from that documentation where this should be put. Is it to be part of sys-usb dom0 allow in /etc/qubes-rpc/policy/qubes.InputKeyboard. If so is there a particular order it should go in?

You can find the guide right on that page:

Open the file /etc/default/grub in dom0.
Find the line that begins with GRUB_CMDLINE_LINUX.
Add usbcore.authorized_default=0 to that line.
Save and close the file.
Run the command grub2-mkconfig -o /boot/grub2/grub.cfg (legacy boot) or grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg (EFI) in dom0.

Those seem like two different steps to me.

It’s not clear from the “Qubes 4.1 only” note at the end of “How to create a USB qube for use with a USB keyboard” that the referred to setting of usbcore.authorized_default is in relation to section “How to enable a USB keyboard on a separate USB controller” which I don’t need.

The documentation is a collaborative effort. If you would like to suggest
an improvement , please do.

I can’t because I do not know what is correct procedure for these steps which is why I asked here.

@disp6252 has pointed you to the correct procedure.
Indeed, from my reading, I do not see where your confusion comes from.
But now that you do know the right thing to do, you should be able to
suggest an improvement that would not lead to the confusion you had.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.