Updating whonix vm (15 - 16)

Hello, I tried to update my whonix template from version 15 to 16.
I followed this guide

Everything runs well for me, sanity test etc. but the name of
whonix-gw-15 and
whonix-ws-15 does not change.
How can I see the current version of whonix in Qubes, I doesn`t find something on the internet that works for me?

you shouldn’t upgrade the whonix qubes/templates in the way, you would do this, when you run a real whonix system.
The best way on QubesOS always is, to download the new 16s templates and replace the 15s versions with them after…

So correct command in a dom0 terminal should be sudo qvm-template install --enablerepo=qubes-templates-community whonix-gw-16 whonix-ws-16
(if you’re on QubesOS 4.1)

1 Like

I am using Qubes 4.03.
So the command doesn´t work. I will try it with the documentation tomorrow.

if you’re on an older version, then it’s:

sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw-16 qubes-template-whonix-ws-16

more infos → here

2 Likes

thanks, the command worked, but I have now 2 gw´s and 2 ws´s.
I can´t delete them and my sys-whonix is still whonix 15.

That’s correct.
You now have to change all templates (named …-15) in the settings of AppVMs to their equivalents named …-16.

And if you have done the changes, you’ll be able to delete the old 15s versions with:

qubes-dom0-update remove qubes-template-whonix-gw-15 qubes-template-whonix-ws-15

I tried you command but I get an error response.
All matches are filtered out by exclude filtering for argument: qubes-template-whonix-ws-15
Error: Unable to find a match: remove qubes-template-whonix-gw-15 qubes-template-whonix-ws-15
When I try to remove the vm´s manually, I get the message:
Vm installed by package manager: whonix-ws-15

Okay, my fault… correct command for removing an old template is:

sudo dnf remove qubes-template-whonix-gw-15
sudo dnf remove qubes-template-whonix-ws-15

But I’m afraid you still don’t have set all to the new templates. So if you shifted all 15s version in the QManager to the 16s versions, have you checked System > Global Settings if there are no entries of 15s versions anymore?
If so, the 15s should be removed proper by the commands above.

2 Likes

thanks that works!
I tried the same with fedora 34, everything works but Qubes doesn´t show fedora 34 as a default disposable VM.

Would upgrading from whonix-15 to whonix-16 on qubes 4.1 remove all the appication/configurations that are installed on my previous whonix-15 disappear?

I would like to update to whonix-16 but i’m afraid it’s not officially released yet by the whonix-qubes developer.

can i update to whonix-16?

Yes - you can! The 16s versions working proper right now.You shouldn’t face any issues…

@Amadeus : building a Fedora-34-dvm is simple. You only have to clone a Fedora-34 (appVM) - name it Fedora-34-dvm and go Settings and set the checkbox “Disposable VM”. Maybe you have to change the label color as well…

1 Like

Thanks, I cloned my whonix-16-dvm and changed the template. I think it does the same :+1: