Update UEFI Troubleshooting?

I just finished fighting through installing 4.1 release on a Dell Precision 5530 and found it unclear if these sections are “up to date”?

Installation completes successfully but then system crash/restarts on next boot

When I tried to run this command:

sed -i -e ‘s/^options=.*/\0 efi=attr=uc/’ /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg"

I would get file not found. I never could find the file. Eventually booting with Grub command efi=attr=uc worked.

Has the file names or locations changed?

Installation finished but “Qubes” boot option is missing and xen.cfg is empty / Installation fails with “failed to set new efi boot target”

When I looked for these files they were not present:

xen.cfg (empty, size 0) - not present
vmlinuz-(kernel-version) - not present
initramfs-(kernel-version).img - not present

Also some addition as to commands to creat xen.cfg would help.

Accessing installer Rescue mode on UEFI

This seemed for me backwards, if I booted from what my F12 menu showed as legacy I got the blue menu without the recovery option.

If I booted the UEFI version of the USB installer then I got a black screen with 4 options:

Test and Install

I am not the most technical but have installed Qubes 3.2 - 4.1 on Lenovo T420, T430, HP Spectre 15-df0013dx, Lenovo Flex 14, and now Dell Precision 5530 with Xeon 6 core.

If I am completely off please let me know.