Update Snapd to a higher version

When using a Qubes Debian template repos, I’m able to install snapd version 2.37, however this version is not able to install most modern Snaps, which require 3.x+. I’m new to Qubes and am not sure how I can add additional Ubuntu PPAs (or similar) to Qubes in order to find software that is more up to date. How can I install more recent versions of Snapd?

Isn’t the latest stable version of snap 2.49.2 ?
I don’t think there’s version 3.x+

Security Disclaimer :warning: I’ll add here a disclaimer that what you’re trying to do may bypass some of the protections Qubes OS affords you. So I would suggest in general to stick to installing the software through the traditional way (packages). The software will not be as updated but most things should be there.

Also, since you’re talking about a Debian template, this question is not specific to Qubes, but rather Debian. I would suggest searching for this issue on Debian forums instead or on a search engine. And then applying said instructions on the Debian Template. Furthermore, due to possible security implications, also consider cloning the debian template so your modifications only stay in the qube where you need said specific software.


I was able to get snapd 2.49 using the Fedora repos, which seems to have partially solved my problemI was able to install the Snap). However, after installing the Snap, it doesn’t appear in my application list, and the application doesn’t launch when I run it from terminal. I have the qubes snap helper installed… Is there some other step I’m missing?

Adding shortcut to start menu

Does it show any error?

It only says

bash: command not found

I’m certain it is the right launch command though and that the app is installed…

I was assuming you had checked the docs but maybe you haven’t yet (most often than not the answer is there):

And do the adding shortcut to start menu as suggested by fsflover.