Update issus Qubes 4.1 NOT using apt-cacher

not using apt-cacher as in Dom0 update error | curl error (37) | code 127 - #4 by whoami

when trying qubes-dist-upgrade - with various options fails with
"Errors during downloading metadata for repository ‘qubes-dom0-cached’:

  • Curl error (37): Couldn’t read a file:// file for file:///var/lib/qubes/updates/repodate/repomd.xml
    Failed to download metadata for repo ‘qubes-dom0-cached’ :
    Cannot download repomd.xml All mirrors were tried"

says to “Get rid of that repo”
sudo qubesctl --show-output state.sls update.qubes-dom0 shows all green ‘Succeeded: 4’
sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing
gives ‘No updates available’

sudo qubes-dom0-update --action=“-v update --refresh” fails

according to yum repolist -y the repo id is qubes-dom0-cached and the repo name is Qubes OS Repository for Dom0

Is there some change I should make in /etc/qubes/repo-templates/qubes-templates.repo to make upgrade to 4.2 sucessful?

Can you post the whole command output?


Using sys-firewall as UpdateVM to download updates for Dom0; this may take some time…
Warning: Enforcing GPG signature check globally as per active RPM security policy
(see ‘gpgcheck’ in dnf.conf(5) for how to squelch this message)
Qubes OS Repository for Dom0
Errors during downloading metadata for repository ‘qubes-dom0-cached’:

  • Curl error (37): Couldn’t read a file:// file for file:///var/lib/qubes/updates/repodate/repomd.xml
    [Couldn’t open file /var/lib/qubes/updates/repodata/repomd.xml]
    Error: Failed to download metadata for repo ‘qubes-dom0-cached’ : Cannot download repomd.xml:
    Cannot download repodata/repomd.xml: All mirrors were tried


Do you have the same output when run this command?

qubes-dist-upgrade --update

Using this has always failed at my standalones, so I deleted them, but after saying ‘OK’ for my six templates after stage 1 it just ends with user@dom0. No error but goes no farther.

There is an option to skip them --skip-standalone-upgrade.

I’m not sure how it works, but if there is no error then it could mean that the first stage finished successfully.
What about next stages? Where do you have the error?

qubes-dist-upgrade just goes to root@dom0

qubes-dist-upgrade --update ends after step 1 and goes to root@dom0

qubes-dist-upgrade -k → root@dom0

qubes-dist-upgrade -k --all-pre-reboot -y --keep-running sys-firewall ->6 templates OK then back to root@dom0

qubes-dist-upgrade --all-pre-reboot -y --keep-running sys-firewall → gives the error
qubes-dom0-update -y qubes-dist-upgrade → gives the error

There were several other variations that I can’t recall. They all seem to either end in the user prompt, give the error, or
stop after step one. One of the attempts skipped the first 4 steps, went straight to step 5 clean up but the upgrade
did not occur. Never saw steps 2,3, or 4.
Once I got ""Errors during downloading metadata for repository ‘3isec -dom0-Currint’ -Status Code 404
Cannot download repodata/repomd.xml All mirrors tried. “”

This meant that all pre-reboot stages 1-3 are completed successfully.
After executing this command you had to restart the system and then perform the final steps:

sudo qubes-dist-upgrade --all-post-reboot

I don’t know whatever you could break something by not following the guide and running the commands randomly.
Try to reboot and then run the all-post-reboot command.

I guess I broke something. Went through the stages fine, in green ending with ‘nothing to do’ on each of the templates, but at the end there was ‘Error on ext_pillar interface qvm_prefs is expected’ and ‘Specified ext_pillar interface qvm_prefs is unavailable’ and ‘line 468: quexec-legacy-convert: command not found’.

Not sure how to fix it, at this point I’d just backup my qubes and made a clean installation.

OK, thanks. Someday I hope to be able to do a clean install.
btw Step 2 is the consistent failure, all templates are ‘OK’ in both
pre and post, it just can’t download metadata for repository “qubes-dom0-cached”. Ah well, maybe my luck will change in 4.3. :slight_smile: