Update issues with Fedora 37 and dom0

Hello, all!

I searched the forums as well as I could, but didn’t see these update issues listed. The trouble with the dom0 update has been plaguing me since I first installed qubes several months ago, but I just have been too busy to get around to posting it, since dom0 seems to update successfully about 25% of the time (which is enough since I can just run the Update GUI again until it does). Still, I’d love to resolve it. Basically, about 50% of the time I update dom0, it shows a red “X” and says that some scriptlets have failed (screenshot below). I think these scirptlets are always part of a kernel…but I may be incorrect. about 25% of the time it will instead show me a green checkmark and the update details will show “------------”. which I saw in another post may be a less than ideal way of saying nothing needed updating. and then 25% of the time it actually shows me updates being done successfully.

For Fedora 37, I don’t know if its related or not, but I have tried now installing the official fedora 37 template twice, and both times it just throws the same set of errors and won’t update. Screenshot is attached for that one too. There are too many errors for me to type them out here in a coherent way, but they are clear in the photos. The top photo is the Fedora 37 update issue. The bottom photo is dom0

Any ideas? I would appreciate any help, as I try to more regularly use Qubes and get these things working for me.

Do we have already a fedora 37 template?

Yes. I don’t know if it’s beta or not. But I installed it just by typing in

sudo qubes-dom0-update qubes-template-fedora-37

So I assume its official… Maybe I am wrong and its not ready?

Hi there,
in my template manager, it reports all fedora-37 in repo: qubes-templates-itl-testing…
Cheers,
M.

I see. So this means they are not ready yet to runs and update officially. So then it is just a matter of why dom0 fails to run update scriptlets for me so frquently. Is that normal?

Hi there.
any logs?
Did You install any cacher or any other service like it?
[user@dom0~]$ qubes-prefs updatevm
what report ?
Cheers,
M.

mila,
Thanks for taking the time to ask. When I type that command into my terminal, it says “sys-firewall”. I have not done any fancy configuration changes; indeed, I am afraid to change anything I don’t understand because I don’t want to break anything :slight_smile:

Ever since the my first Qubes 4.1 installation, this issue has happened frequently. Maybe it has something to do with running “kernel-latest” instead of default?

Hi there,
I’m sorry but kernel-latest never covered by me…
:sweat_smile:
I hope it will fix itself soon…
Cheers,
M.

Hi. I don’t think it has anything to do with kernel-latest, I’m using the default kernel and I’m getting the same error. Actually, since I’m using apt-cacher-ng for the updates, I used to think it was the culprit but after reading your post I guess we just gotta have some patience :wink:

1 Like

Fedora 37 being unable to update through Salt is a known bug:

3 Likes

Thanks for linking that! I don’t think that was in the forums anywhere; do you just check the Qubes github and search there for bugs like that? I haven’t really delved into github much yet, but perhaps I will need to so I can check on things I might have issues with.

You can follow the new created bugs with :

Hi,

I have a noobie question with regards to Fedora 37; if the template isn’t downloaded/not ready is there any point in updating via the GUI using Software for qubes individually?

Thanks

Can you rephrase your question, please? Beacuse, it is not clear to me

What does this mean?

Updating what?

?

Hi @enmus thanks for your response:

This thread is about updating Qubes to Fedora 37 (which is what I’m trying to do) and the fact that it is a Beta version and not officially ready for normal users to use (this is my understanding). My question is in relation to individual qubes as when you select the software option via the Qubes manager (which links you to Fedora repository) it asks you to update to Fedora 37 - I’m assuming this is just for the individual Qube you are currently using!? I take it we should wait fro the Qubes team to officially update and release the fedora 37 Template and then we update the individual Qube qubes via Qubes Tools in Qube management? Hope this is clearer!

Can anyone else help with this?

Can you post a screenshot of this?

Definitely! It’s one of the first things users should do when they think they’ve encountered a bug.

Hi all, thanks for your responses; I think I’m going to wait for an official release so as not to confuse myself as I don’t believe it’s a bug; just knowing when a new release has been verified and then how best to update, via the GUI from a terminal…

Thanks again