Untrusted Application Launcher

Having downloaded LibreOffice with these steps, “Untrusted Application Launcher” prompt appears after making desktop launcher. Why is that?

Thank you.

The why may be a better question to the LibreOffice folks, from the DNF installer I’ve never had a prompt show up for any desktop file. But I would say it doesn’t hurt. Can you provide a picture?


Not sure yet to screenshot and bring to a Qube. This is text:


Untrusted application launcher

The desktop file “LibreOffice: LibreOffice Base.desktop” is in an insecure location and not marked as executable. If you do not trust this program, click Cancel.

Exec=qvm-run -q -a --service – LibreOffice qubes.StartApp+libreoffice-writer

Launch Anyway Mark Executable X Cancel

*Accidentally deleted earlier.

This is very strange. I was looking at my launcher for libreoffice and it looks exactly the same.

So try the following:

  1. Open the “LibreOffice: Qube Setting” application
  2. Go to the “Applications” tab
  3. Click the button “Refresh Applications”

Whatever issue with the desktop file permissions that happened should get resolved by this. If not, we’ll have to dig deeper.


Did refresh applications and same error persist. Launcher for Qubes Manager on desktop brings same error prompt, with different code.

Anything new?

Unfortunately not. I don’t know what else to test to understand what the issue might be. perhaps installing it on another template?

1 Like

Why not just install LibreOffice from the Fedora repos and be done with it? It’s more secure and doesn’t have this problem. No need to make things harder than they have to be.


Will look into. Is the version most recent?

That’s up to the LibreOffice package maintainer for the Fedora repos. It’s not a Qubes thing. You can just check in the repo to see which version it is, e.g., sudo dnf info libreoffice.

1 Like