Understanding backup structure

I want to make a fresh install of the new qubes 4.1. The thing is, I don’t really understand the backup structure.

If I make a backup of the standalone-VMs and app-VMs, how will I get them back in the new qubes 4.1? For example there are some fedora 33 standalone VMs and also some appVMs with fedora 33, but the new qubes has fedora 34. So i think, I must upgrade fedora first and THEN make a backup of them all, isn’t it?

Or is it so, that the appVM based on fedora 33 will just run with the fedora 34?

The next thing is. I made a backup of a standalone VM and resotred it (just to test). But it the restored VM I have no apps within. Just “start Qube”. So I see no files and no software within, not even a file manager.

Can somebody help? Thanks!

Best regards

1 Like

Correct! So whether you do the backup (before or after a fedora upgrade) - these qubes can work with any kind of template (Fedora, Debian, Kali, Whonix, etc…).
And althrough I know this, I always do a backup (before and after I updated the templates to the next higher version).

If you made a backup of a standalone VM, you do this of a full system - so you don’t have to think about apps or stuff in there. So if you’re talking of a standalone VM, then it’s just about backup of a complete OS (Windows, macOS, Debian, Fedora, Kali, Ubuntu, etc…)

ah, ok, thanks!
So if I’ll make a backup of all the AppVMs and delete the whole SSD, then make a fresh install of Qubes 4.1, I will get all the data of the appVMs?

The thing is, I have no software within after I restored the backup of the standalone VM, not even a file manager. So whats the problem there?

Backup should restore all properly. Never had any problems, except of a (how’s that called?) “Windows Qube”… this one didn’t start anymore. But maybe it’s because I tried to use this qube from a 4.0 backup in a 4.1 rc system.

But with all other (Linux standalone & App-)VMs, you won’t have any problems.
Not sure, what happens if you try to move a Qubes 2.x or 3.x backup in a 4.1 system… Theoretically even this should work fine.

hmm… strange. In my case it restore the appVMs properly (just tried it), with all data. But in the case of restoring a standalone VM, I can not start any software within. It shows me just Qube Setting and Start Qube, no file manager, no terminal, just nothing.

I have also a Windows Qube, so we’ll see, if it can be restored.

For the windows qube - just do a backup from a 4.0 version FOR another 4.0 version or from a 4.1 for 4.1. This will work I think.

For your other issue: Standalone means - all apps are inside the VM or have to be installed inside of the VM - very same you will do in a Windows VM. You don’t have any apps in a Windows VM, expect Start cube and settings. Very same with other standalone VMs.

I have the strange feeling, you backupped a previously build AppVM, which now (on the new system) appears as a standalone VM, after you played back the backup.
I have the very same with my sys-vpn qube, which I build as a App VM on the old QubesOS and now my backup moved it to a standalone qube…
I currently have no answer for this and have to check in the next days, whats going on here… I rather would think of an error by myself, then a bug of the backup routine.

I have now 4.0 and want to make a clean install of 4.1. So as it seems the restore of the Win VM will not work properly, isn’t it?

No, no, I just make a backup af standalone and restored it (just to test). So it appears as standalone1, but without any app within. The standalone shows me the installed apps (software) within, such as terminal, firefox and so on. The restored one shows no software within. So I can not even look, if there is all data copied or not.

50/50 chance I guess. From my testings, I only can say, it didn’t worked for me.

strange! This should appear on templateVM or AppVM only. How’s this qube called?
Ahh, and I forgot. Just take a look in the settings of this qube. Especially on the Applications Tab. There you’ll find all possible apps on the left side and maybe you only have to move those you want to the right side. Should bring back that, what you’re missing.

ah, ok… so let’s see :smiley:

yes, I know this point, but there is also nothing but “start qube”. Very strange.

Yes, and thats quite normal for Standalone VMs. So whatever you had on your machine before that test-backup, I’m really curious if it probably was somethings different - means: it was an AppVM (where you chould find several tools unter Settings > Applications) and not a StandaloneVM (with more Apps as of “Start Cube” unter Settings > Applications).

Maybe you can send us a pic of this first state…

it was/is 100% standaloneVM.
I think, I get the problem…suppose it has to do with low disk space for LVM, so it could not recover the vm properly. I try to manage the space problem and will reproduce it again.

#Edit: no, just the same again. Have enough space. Backuped standaloneVM, restored it and have no software within… no file manager… nothing. Also nothing to choose in the settings/applications. Just “start qube”.

1 Like

Some people, including some core developers, are interacting with this forum via email. They do not receive the edits made after 10 minutes. For this reason, it’s better to make a new post, not update the old one (and/or use quotations like I did here).

thanks, good to know!