Under a Fedora-33 AppVM, the ProtonMail Bridge app needs to be launched twice before having the declared accounts visible


I’m posting here as long as ProtonMail support folks are LAZY folks that indeed don’t bother solving customers issues.

I’m a protonmail user, and recently, I decided to use the Protonmail Bridge App (V1.8.12) with Thunderbird on my Qube-OS computers, but I encountered a small but very annoying issue :

  • I have installed the Protonmail Bridge app rmp package in the Fedora 33 template used by my Fedora-33 AppVM, and everything went fine.

  • Once the installation is done in the template, I launched my Fedora-33 AppVM and then launched the Protonmail bridge app, declared the protonmail accounts I wanted to use, and everything went fine. The Bridge app created a new entry in the “Default Keyring” and the keyring daemon asked me a password to protect the “Default keyring” : Everything went fine. Then I successfully configured Thunderbird to use the bridge, and everything went fine too. It works perfectly.

The issues come after this, after shutting down my Fedora-33 AppVM, and later on launching it back again :

  • I start the Fedora-33 AppVM used for the Protonmail bridge and Thunderbird.
  • I launch the Protonmail Bridge app, the keyring manager asks me the password that is protecting the “Default Keyring” : I type the correct password, and then the Protonmail Bridge windows appears, but all the protonmail accounts I had previously declared are not present. There is not account declared.

From here, I am forced to manually shut down the Protonmail Bridge app, and launch it again (And this time the system doesn’t ask me the password for the “Default Keyring” as it was previously entered successfully and the keyring was successfully unlocked) and the Protonmail Bridge window appears, but this time, the previously declared protonmail accounts are correctly displayed, and I can then launch the Thunderbird app, and everything works fine.

The issue is that I have to launch the Protonmail Bridge app twice to have it in the normal state and ready for thunderbird.

Does anyone have an idea why the unlock of the “Default Keyring” triggered by the first launch of the Protonmail Bridge App doesn’t seem to forward the correct informations to the Protonmail Bridge App ?

Does anyone have an idea how to solve this ?

Is it a Protonmail Bridge app bug related to the keyring manager access, or is it something else ?

I am looking forward to hearing from you.

Kind regards,


I don’t use it, but in principle I’d clone a template (or better, create completely new one), connect it to netVm, would do the whole job you did in your AppVM, restarted the cloned template, and if everything still works as expected, then would create an AppVm from the cloned template, and would try to use it now.
If you are concern about connecting the template for a short to netVM, then I’d consider to create a disposable template and would try to do everything there for once.

If it doesn’t work in template, then I’d probably wait for others to suggest, while thinking it’s rather protonmail issue.

Note that Fedora 33 is EOL:

1 Like


Ok I reinstalled everything with a Fedora-34 Template and I change the AppVM to use the new Fedora-34 template, and the same issue is there.

To me there is a problem with the keyring daemon and the Protonmail Bridge app : It doesn’t seem to get the right informations just after the “Default keyring” is unlocked.

I will try this too, and let you know how it goes. Thanks for your time.

While you’re at it, try using the latest bridge (v 2.1.1).

I tried already, both from a Fedora-33 and a Fedora-34 template, and the issue is still there too.

I am going to take a video of my screen and post a link of it here so that you can see the fuckery by your self.

It is very easy to reproduce for any person that has a protonmail account.


Here is the video of the bug on my Qubes-OS machine :

I am looking forward to hearing from all of you.

Kind regards,


@stman I see that you updated the link. Some people are using this forum via email system. They will not receive any updates done after 10 minutes. It would be preferable to make a new post for them. Here is the updated link:

Hidden text

270.56 MB file on MEGA

Thanks for the video, but for me it didn’t bring anything that wasn’t clear from your opening post.
While it is not clear enough (for me at least, since English isn’t my first language, too) if you tried to set thunderbird and your account in protonmail-bridge in fedora-34-thunderbird (if it’s template VM at all) while it is connected to sys-whonix and tried all to use it from within template, as well as if you installed latest version of protonmail-bridge as @Raphael_Balthazar proposed, or did you try to do it other way (with debian or whonix, for example), or with the steps taken in different order, or if you checked their issues on a Github, for example this one, while all the time keeping on mind what’s the best way to seek for a solution, without any concrete evidence somehow I feel this is not Qubes OS related and I am sure that you have every right to ask their support to resolve this issue for you because you are paying for it.

As I wrote, beside my best will and what I already proposed, I’d probably wait for others to suggest something else.

But the first option I would consider is that this might be an absolutely insignificant issue to invest the energy into resolving it to, because with a “workaround” that “costs” literally 3 quick mouse clicks more, you get fully functional service.

Let me try one last things : Doing the same from a standalone qube derivated from the fedora-34 template I am using for Thunderbird.

It could be that a configuration file somewhere is immutable while it should be mutable. This often happens with Qubes-OS.

Still, I have sent the video to the Protonmail user support too. But for now, they are not very reactive.

Such bug should be found in 5 minutes by the developper who coded the Protonmail Bridge app if he would run it with a debugger. It’s a small but very anoying bug.

There are many paranoid protonmail users that use Qubes-OS. But it’s like not that much is using the bridge app.

I think that those who use it did it with a standalone qube.

Yes because I am not shure the MP4 conversion of the video is working fine for everybody, so better keeping the original video file from my recorder, even if it’s way bigger.