Unable to reset PCI device error occured while in installation

Hello everyone,

I’ve tried to install the Qubes to a new laptop and found several problems.

First of all, I tried to install the OS using the default option - check everything and then install with default kernel (second option from the list).

I don’t know what exactly wrong, but I faced with a rendering problem. Render (updates on the screen) are terrible slow. Like frupdatedom the old films when screens were updaupdatedting line by line.

Anyway I installed it and found no luck, the system has the same rendering problem after installation (I thought that it’s only installation process problem).

After that I reinstalled the OS using the last option from the list (using the latest kernel). It has no this problem. Render works fine.

I had no problems at all except the last installation step. Where Fedora, Debian, Whonix, etc templates are being installed. After several templates installed I got an error with the next message,

[‘/usr/bin/qvm-start’, ‘sys-firewall’] failed:
stdout: “”
stderr: "Start failed: internal error: Unable to reset PCI device 0000:00:1f:6: no FLR, PM reset or bus reset available, see /var/log/libvirt/libxt/libxt-driver.log for details

I found a thread on this forum with similar problem and removed the PCI device from resetting list in the sys-net qube settings. Now it works.

But I DO NOT SURE that everything was installed as it should. I DO NOT SURE that all scripts were executed as they should. Because step #N was failed.

For example, usually I see in the start menu list of disposable vms (fedora or debian). And I’m able to start Terminal or Firefox, but now I did not. I found that problem was in the settings of debian-11-dvm qube. It had Firefox-desktop and xterm application, when Firefox ESR and terminal are correct (base qube [debian-11] just had no application with the names).

It’s small mistake but I DO NOT SURE that there is not anything more serious (rules, security politics, etc). I can’t check it myself because I don’t know the Qubes well (on admin/dev level).

I’d like to ask for help. Is there any way how to mitigate this error on installation steps? Or maybe there is a way how to redo/re-check all things that may not be executed because of the error?

I do appreciate any help. Thank you!

Additional information,

My laptop is thinkpad t14 gen3 (intel 1260p).
Problem PCI device is built-in ethernet port.

You can rerun the the post-installation wizard with sudo /usr/libexec/initial-setup/initial-setup-graphical.