Unable to mount encrypted partition

I have an external ssd disk with an old qubes installation (encrypted btrfs) that I want to access using thunar on disposable sys-usb (based on debian 11 ) working correctly.
The problem is when I want to access its encrypted partition it never does.
It asks for the key but stays there… wanting to decrypt to infinity without showing errors.

Well… if the procedure is done in appvms based on whonix I access correctly, so I guess it is lack of some package that I have not been able to identify (I guess).
I have tried with Nautilus but it is the same problem.

I have the following packages installed:
qubes-usb-proxy qubes-input-proxy-sender qubes-core-agent-thunar thunar zenity policykit-1 libblockdev-crypto2

thanks and sorry for my english (it is not my native language )

Is cryptsetup available?

Because of the timeline + a bit of a shot in the dark here …

Is it a by chance a Samsung EVO model? If so, it may be worth investigating the “Samsung EVO trim bug”. I ran into this myself with Qubes. Thus far, I’m still unable to accept this “loss”.


thanks @cayce for your time…

no, its a Western Digital Elements


vchan closed
vchan closed
vchan closed
vchan closed
+100 times

Will it have something to do?

As a last resort, maybe on each qube (debian-11-based (non-fuctional) & whonix-*-based (functional)) just run:

apt list --installed

And, diff the output?