Unable to locate package qubes-tunnel?

So, I’ve also been trying to setup a vpn using the qubes contrib method. So I installed qubes-repo-contrib package using apt-get on a debian minimal 12 template and it seemed to go fine (no errors) but then I tried to install qubes-tunnel:

sudo apt install qubes-tunnel
reading package lists... Done
Building dependency tree ... Done
Reading state information... Done
 E: Unable to locate package qubes-tunnel

I tried to install something else, terminator in this case and it finds terminator asks if i want to install it, then starts spitting things out like “Temporary failure resolving deb.debian.org”?
Its not clear to me why it can “see” some packages but then not be able to download them?
I’ve run sudo apt-get update && sudo apt-get upgrade a few times and it tells me some index files failed to download. Any thoughts why this might be happening?

Qubes-tunnel package is currently in Qubes contrib updates testing repository (bookworm-testing).
You need to enable this repository in /etc/apt/sources.list.d/qubes-contrib-r4.2.list:

# Qubes contrib updates testing repository
#deb [arch=amd64] https://contrib.qubes-os.org/deb/r4.2/vm bookworm-testing main
#deb-src https://contrib.qubes-os.org/deb/r4.2/vm bookworm-testing main

Then install qubes-tunnel package from testing repository:

sudo apt update
sudo apt install -t bookworm-testing qubes-tunnel

Are you trying to do this in debian-12-minimal template or in standalone/app qube based on it?

So I enabled the testing repo (un-commented those two lines in the `/etc/apt/sources.list.d/qubes-contrib-r4.2.list) ok, then update seemed to go ok, but then when I ran:

root@debian-12-minimal:~# sudo apt install -t bookworm-testing qubes-tunnel

I got:

Reading package lists… Done
E: The value ‘bookworm-testing’ is invalid for APT::Default-Release as such a release is not available in the sources

What’s the output of these commands in your template?

cat /etc/apt/sources.list.d/qubes-contrib-r4.2.list
apt update

ok, so I paid more attention this time and interestingly, this is what is in my /etc/apt/sources.list.d/:

root@debian-12-minimal:~# ls /etc/apt/sources.list.d/

There is no qubes-contrib-r4.2.list?

Did you remove qubes-repo-contrib package afterwards? That file is provided by this package.

1 Like