Unable to get fully functional system when installing Qubes 4.1 on a RAID1

My first attempts at installing Qubes 4.1 on a RAID1 left me with a system where I could not run backups while any of the qubes being backed up were running. This was a bug documented here:

The solution proposed there was to try BTRFS instead of EXT4 for the file system for root.

Took me a while to figure this out in the installer, so I will document the steps I used to do this:

  1. on the “Device Selecting” screen I checked the two 1TB drives I had used for my RAID1 install
  2. I clicked “Custom” for the partitioning
  3. In “New Qubes OS R4.1.0 Installation” I left the existing EXT4 RAID1 partition for the boot and mapped it to /boot and deleted the other EXT4 RAID1 partition for root that was most of the disk
  4. I clicked “+” to add a partition
  5. set mount point as “/” (root) and capacity as 920GB (for a 1TB drive) and click “Add”
  6. on the right hand portion of screen I select Device Type = BTRFS
  7. click the “Modify” button (this was the secret that took me a while to figure out)
  8. In the new pop-up; I checked “encrypt”, select Raid Level=RAID1 and select Size Policy= “as large as possible”

After that I re-installed Qubes OS 4.1

When I run
dom0$] lsblk

It shows /dev/sda1 and /dev/sdb1 as MOUNTPOINT = /boot
However, while /dev/sda2 MOUNTPOINT = /
/dev/sdb2 does not show a MOUNTPOINT

If I mount /dev/sdb2 it appears to be a mirror of /dev/sda2. Maybe RAID1 is working? but lsblk does not indicate that it is a RAID.

While I was happy to find that backup tool now works as expected. My system load is constantly getting very high. I am referring to “Load: 2.52” in the bottom bar on i3. From what I read this indicates the wait for CPU resources.

If I run ‘xentop’ in dom0 my CPU% use looks similar to what it was on EXT4. But the “load” is constantly ramping up in the 2.5-5 range, and often into the double digits if starting or stopping a qube. This means updates and backups are a real drag on the system. Conducting normal operations that were no problem on EXT4 lead to things like music player pausing every few minutes and slow scrolling on browser windows in BTRFS.

Most of what I’ve read about BTRFS and Qubes is that it improves performance.
However, in the link to github above, DemiMarie mentions that " I/O performance can be unstable" with BTRFS. Perhaps this is what they were referring to?

Any suggestions for a more usable Qubes install with RAID1 redundancy?

Just a feedback, I’ve installed Qubes OS on a server with two NVMe and did a software RAID1. I admit I had to fight a bit with the installer and we definitively have some bugs. I’ve not selected BTRFS but standard ext4 for the root volume. I think this is a setup we need to implement and validate because some of those bugs prevent me to install Qubes on another machine. On other servers, I’m relying on hardware RAID card directly.