Unable to change password

Hi, I’m trying to rotate my password using the password reset option in the security section of preferences, but I never receive the email. In particular, I have tried this set of steps multiple times over the past few weeks (I double-checked my spam box and that the email address on my account is correct):

  1. Open forum.qubes-os.org and log in
  2. Click on the circular profile icon in the top-right corner
  3. Click on the silhouette button (bottom-right corner of the pop-up)
  4. Click on the “Preferences” button
  5. Click on the “Security” tab
  6. Click on the “Send Password Reset Email” button
1 Like

From the logs it appears to have been sent. I’ll need to investigation this later.

2 Likes

Since your logs say that the email was sent I’ll double check things again on my end. I thought I checked everything but maybe I missed something. I am only human after all. :slightly_smiling_face: If I find something I’ll mention it here so that we know the issue is resolved.

3 Likes

I’m still not seeing it. In another forum running discourse that I use the subject line is “[forum name] Password Reset”. In this case I would expect it to say “[Qubes Forum] password reset”.

Emails I have received about posts being made have come from “qubes_os@forum.qubes-os.org”. I would expect the reset email to come from the same address.

Are these expectations correct?

It comes form this one. I have just tested the pw reset myself and I have received an email from that address. The loogs look the same as the pw reset you sent yesterday. So I think the problem is somewhere in your email provider / client. Maybe it got filtered or went to spam?

I am at the limit of what I can do for you in this situation. Maybe try changing email? The forum supports disposable providers.