Unable to build 4.1 iso: rpm --initdb fails


I need a newer kernel so I’m attempting build the 4.1 ISO. It failed on fedora 32 (and 33) with rpm --initdb.

+ rpm --initdb --root=/home/xxxx/src/qubes-builder/chroot-dom0-fc32
make[1]: *** [/home/xxx/src/qubes-builder/qubes-src/builder-rpm/Makefile-legacy.rpmbuilder:44: /home/xxxx/src/qubes-builder/chroot-dom0-fc32/home/user/.prepared_base] Error 1

I believe this is an issue with Fedora rpm, and have filed an issue: https://bugzilla.redhat.com/show_bug.cgi?id=1906289


Hi @face,
Not related to your build issue but related to your 4.1 iso need. Did you already try this below alpha 4.1 alpha iso?

Nice, thanks @ludovic. While I knew the alpha build existed, I never tried it because the only kernel which fully supports this new laptop is 5.10-rc7 (for audio and wifi drivers). I had no luck even installing 4.0.4-rc1, even with all the troubleshooting guides (install kernel would hang). So I was going to build a 4.1 iso using a newer kernel (the just merge 5.9.12…living on the edge).

However, per your suggestion I tried the official 4.1 alpha build…and to my surprise the install worked perfectly. Didn’t even need to blacklist nouveau for the nvidia card or anything. It simply worked!

Once I get audio and wifi working, I’ll post a full hardware report on the wiki. The audio already has some dkms sof/soundwire drivers backported from 5.10, but the wifi needs the ath11k driver which I’ll have to backport myself…or wait till 5.10 is released and merged into qubes-kernel.

My only hiccup was the installer advised me not to create a sys-usb qube due to a usb keyboard…which then made it impossible to get usb networking into sys-net. Once I found sudo qubesctl state.sls qvm.usb-keyboard to setup the sys-usb qube, I was able to get devices into sys-net and have temporary usb wifi and ethernet working till I can backport the new ath11k drivers.

Thanks again.

Hi @face,

Good news!

When ready you could do your hardware report as an HCL report (use the hcl doc).

I’ll ad the HCL report as soon as things are stable.

Update on the original issue. Fedora determined it is a selinux issue with rpm, so I am able to continue my qubes-os build by temporarily disabling selinux (I’m doing this in a boxes vm, not my main system): sudo setenforce 0

Without selinux in the vm, rpm works and qubes is now building.

I’m having some other issues with the kernel in qubes 4.1, like the fans are always on high and there are some performance issues. I’m going to test newer kernels to see if it helps.