Unable to Access Internet (New User)

I am brand new to qubes and have no idea what to do. I have a librem 14 with pure boot and wireless card. I installed qubes and can run everything but the internet. I have tried loading devices into various VM’s to no avail. It seems from what I’ve seen online that it just works out of the box but I haven’t been able to get it to work. There’s no section I’m aware of in the documentation from qubes about how to connect to the internet. What should I do?

Hi there! First of all, welcome to Qubes!

Good point. Borrowing @ninavizz’s design to explain this. See the part bellow the mouse:

Also note that that is a design concept. Not something that is implemented in Qubes.

Let me know if that helps.

1 Like

Welcome to Qubes.

One of the important lessons to learn is that many problems arent
Qubes problems - they are issues in the distribution used in the qube -
in it’s template.
The Qubes docs don’t repeat things that can be found elsewhere.

You don’t say which version of Qubes you have installed.

At the top of the screen you’ll see a task bar, and in the right hand
corner you should see an icon of 2 computers, one behind the other -
this is the icon from sys-net that you use to control networking.

If all is well, you should be able to click on this icon, and see
the name of your WiFi router: select it and you should be prompted for
your WiFi password.

If you don’t see any WiFi networks or WiFi is not available, then it may
be that the WiFi adapter is not attached to sys-net.
Open the Qube Manager.
Shutdown sys-net.
Open settings, go the the Devices tab, and make sure that you have the
Network Controller for WiFi in the selected list. If it isn’t there, add
it, and restart sys-net.

If the controller is already attached to sys-net, it may be that it isn’t
working with the Fedora template that is the default. You can try using
a Debian template, by shutting down sys-net, and changing the Template
on the Basic tab of Settings.

(If you see warnings or are unable to shutdown sys-net when you try, you
can Right click on the sys-net icon in Manager and select Kill from the

1 Like

I am using Qubes 4.04-x86_64. It gives me 4 different qubes versions when booting up which is confusing.

I tried what you said unman but it hasn’t worked. I added ethernet and networking to sys-net but it doesn’t do anything. I also tried switching it to debian but no luck. I got an error that said “domain sys-usb has failed to start: PCI device dom0:01_00.0 does not exist.”

Even worse the icon you indicated, the two red computers, are completely gone. No idea how that happened as it was there the entire time prior.

I haven’t been able to locate the help screen in that photograph. Do you need internet capability for that?

Hi Yellow! The screenshot Deeplow previously shared, is a design mockup that I made. That UI does not exist. Anywhere. Outside of my drawings. :smiley:

Hang in there. This is hard… but Unman and Deeplow are two knowledgeable and caring folks, so you are in good hands! And yes, “we” (the broader community of longtime users also working in tech) are working on making this climb much easier for new users, in the future. Deeplow, especially, with a tutorial he’s been developing.


Sorry for the delay in replying.
The " 4 different qubes versions" is standard fare in Linux. You should
always try the first entry, as that should have the most recent
kernel/Qubes versions.

I don’t know if you have managed to solve your problem.
Obviously, the error message is clear - you have attached some device
that is no longer present. Just remove it using the devices tab under
qube Settings. But focus on one problem at a time - let’s get sys-net
working first, then move on to sys-usb.
Let me know what the current position is.

I’m sorry for the late reply. I have everything fixed, have internet access, and think the issue was an incorrect setup across the system leading to having internet blocked.

I can’t pick option 1 when I boot up because it errors out. When I select option 2 it allows me to continue but still has errors. Then just before it loads the Qubes LUKS password prompt more errors. I’m not sure if it’s regarding the Librem key/boot setup or if Qubes is just being weird. Any ideas?

I’m afraid I don’t know what Options 1 and 2 are, because you haven’t told
If you could tell me i might be able to help.
Similarly “errors out”, “has errors” and “more errors” doesn’t give me a
great deal to go on, other than that you have errors.