UEFI Bootloader Broken- Unable to Get into Qubes


This morning I found that my Qubes bootloader was unrecognisable to my bios. I dualboot (and have been for a couppe years now) with Windows 10, so I’ve using it to troubleshoot.

This is the first time this has happened to me. I updated dom0 and partitioned Qubes (leaving able storage) yesterday, if it helps at all.

Here’s what I’ve tried:
-Using a usb bootable of Qubes to rescue the bootloader
-Messed around with bios UEFI settings
-Tried using the “rEFInd” tool from usb, though unsure if i set it up correctly.

Unsure where to go from here, none of the options above worked for me.

Thanks for any advice in advance.

Try the efibootmgr tool from a USB boot disk

First just try to issue the command without any flags and post the result here.

1 Like

Hi Oli.

Attempted this again, here are the results:


Previous issue with the flash drive was due to an iso mount error, haven’t read the documentation in a while. :slight_smile:

Anyway, the rescue environment doesn’t recognise the Qubes partition. Here is the result of the efibootmgr command again:

I also inputted this: "efibootmgr -v -c -u -L QubesOS -l /Efi/qubes/xen.efi(andgrub64.efi) -d /dev/sda -p1(and to the genuine Qubes path), to no avail.

Any thoughts?

Hi uefibusted

Sorry for the late reply, been away.

This screenshot tells us that the EFI looks first in Samsung SSD 850 EVO 500GB device for something to boot on. And probably it will see the Windows Boot Manager there.
So my guess is that you need to either tell the Windows Boot Manager about Qubes or reinstall Grub2 (assuming that you are using Qubes 4.1 or 4.1.1, they switched from EFI boot to Grub2 boot between 4.0 and 4.1).