U2F sys-usb unmet dependencies

I followed the directions in the 4.2 Qubes OS Global Config, USB Devices, U2F devices section, to install qubes-u2f
The error I get there is ‘qubes-u2f : Depends: python3-u2flib-host but it is not installable’

Is that pending?

In what template did you try to install this package?

I’m at work on break so don’t have my laptop up to check, but I think it was following the instructions on

If I remember correctly, fedora worked OK, but debian (that the sys-usb was based on) didn’t work. I can’t remember of the dom0 part of the instructions worked correctly.

Was it debian 11 or debian 12? Seems like debian 11 has this issue.

It was debian 12

Tried rebooting, updating, installing again.
debian-12 does Not work (depends: python3-u2flib-host but it is not installable) .
debian-12-minimal Does work. weird.

Did you upgrade this template from debian 11? Maybe it didn’t upgrade it didn’t upgrade correctly and there are still old repositories?
Did you update your template before trying to install this package?


i did upgrade it, and the debian 12 upgraded correctly from 11 as far as I know

What’s the output of this command in debian 12 template?

sudo apt update

it didn’t have any updates available…

i did a nano of /etc/apt/sources.list and the other one, and it looks like they didn’t get changed to bookworm during the Qubes 4.2 upgrade… changed, and hey-presto, lots of updates now available… upgrading… will try again in a few hours (or after i sleep, it is past time in my timezone…)…

if that was a mistake, i’ll see y’all’s wise advice in a bit.

1 Like

If anyone searching through the forums because they’re having similar issues with installing the U2F proxy, check out the suggestions from @apparatus and possibly sudo nano your sources to check if the debian template needs to be updated…
I was able to follow the directions and see the options in the Global Config now as well.
Thanks for the help!