Trying Qubes With USB

Hey everyone,
I am new to QubesOS and wanted to try it out by booting from a USB, but I am having some issues. Besides taking awhile, going through the installation wizard and installing to the USB seems to be completely fine. Then booting into the system will go into the initial loading screen fine, but then after it will just switch to a black screen. The first black screen has a blinking cursor at the top left, and then after it is completely finished loading, it turns completely blank.

I tried switching to other TTYs, didn’t work. I am not sure if this is a hardware or user error. My device does have a NVida GPU, but it also has a IGPU supporting Intel VT-x.

Is there anything I could try to troubleshoot this?

Did you try installing Qubes OS with kernel-latest?

Or you can try to add grub options nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off:

I tried adding the parameters that the guide said to the GRUB, and no luck. Regarding which kernel I installed, I am not sure, just used the Qubes release 4.1.2 from the downloads page.

You can try to install Qubes with kernel-latest.
When you boot the installer it’ll show you multiple menu options in GRUB and there is a menu entry Install Qubes OS with kernel-latest or something like this.

I am running the installer again right now with the latest kernel, which may take awhile. Thanks for your time.

Did not work. Very sad.

After installing with kernel-latest, did you try to edit the kernel line (starting with module2 /vmlinuz...) and add


– and maybe removing quiet? :slight_smile:

This also did not fix it unfortunately. I think it might be an issue with the installer though because I just looked at the drive in gparted, and for some reason 56GB (out of 64GB) was in use.

Does the installer normally write this much data to the target drive?

Did you Test your media in Qubes OS installer to check if the media is not corrupted?

Yes. Every time it told me my installation media was stable.

As a side question, is there a more optimal way to run the installation for a USB other than having the Qubes ISO on one USB drive and have it write to another?

Maybe installing it it VM, but I’m not sure if it’ll work well.