Trusted converters: progress bars without progress

Hey guys, I am not quite sure if anyone is having the same issue, but for some reason when i initiate trusted PDF and trusted img in any vm the progress bar does not load even though the files appear to be converted. I thought maybe this would be fixed in the update but it still functions the same way. is anyone else having the same issue?

yes, it hangs.

Progress bars are really hard to implement.

Have not tested it, but i would assume it works better if you convert multiple PDFs at once?

It still doesn’t load. how can this be fixed?

My progress bar doesn’t move at all. Not even an inch.

No progress until completion for single file conversion, where when finished, converted file stands beside the original as expected.

I don’t recall a moving progress bar before, hence cannot confirm/infirm a regression from the past without looking at the code. But what would be expected progress here, since the caller is holding the progress bar? Having a progress bar here would imply that the dispvm sends some kind of report to the source qube. And what that would that progress be? Number of images extracted to dispvm from original pdf? Then a report from command line from the img-to-pdf app on dispvm?

Basically, what i’m saying here is I think the absence of progress bar here is what I would expect.

@NicholasTrust You recall a working progress bar when converting PDFs? You imply that no progress bar is somehow a regression from a different behavior observed in the past? Or you simply wished there was a progress bar but there isn’t?

@NicholasTrust No expected progress bar movement here!

The progress bar did load before and does on load now but it does on other Pc’s. As it relates to trusted PDF, after the process has finished there is no new converted file only the original file tha was converted. According to your statements, this would not be normal behavior, Since the there should be a new file .Trusted.PDF and the original file that was converted but its not in my case. Could this indicate a compromise?

I can redo.

Downloading under current qube, save link as.

From command line of that qube:
qvm-convert-pdf ~/Downloads/x86_harmful.pdf
See progress bar of X/56
And then the pdf is replaced with ~/Downloads/x86_harmful.trusted.pdf

So there may have been some progress bar, sorry to have misled this.

Redoing the download into a fedora-36-dvm for gui version.
Opening a fedora instance. Pointing it to Intel x86 considered harmful (new paper) | The Invisible Things Blog
Right clicking to save pdf (save link as).
Download manager, show in folder.
Right click on file, convert to trusted pdf.
Not doing anything. looking at the progress bar.
I see no progress. Just the window closing.
And the original file is deleted (x86_harmful.pdf) where x86_harmful.trusted.pdf replaces it.

Can you do from command line and give the output here?
On my side I cannot replicate, and the command line gives more information then a GUI that opens and closes if no progress is given.

there are also other threads on this forum. I would also advise into renaming this post to something more relevant then Progress bar not loading. Progress bar of what? What is the disposable’svm template in global configuration? Details that would help people answer to your question. There is not enough meat here for anyone to be able to help you even if they wanted. Have you tried from another dispvm template? debian-11? whonix-wks-16? fedora-36?

That behavior alone without further details or troubleshooting is highly improbable. Are you trying to convert a 10000 pages document? Is the process getting killed because there is not enough memory available? Some more details would be needed. For example, downloading the same paper here, and attemtping a conversion from command line. And reporting here if that works, answering, maybe, some of the questions here maybe even some of yours.

Edit: similar if not duplicate Trusted file conversion progress window

I convert one file at a time not multiple i have tried though and it says the same thing. This is happening only in Disp VM ( progress bar window issue). Original file is supposed to get deleted automatically when converting to trusted PDF?
I am assume so, but not quite sure.

@NicholasTrust I can only repeat myself, with different words.

What is the templatevm used for dispvm where conversion is happening? What does qvm-convert-pdf says on the console output for the whole operation? Do you see progress there? (I did).

The goal is to have replicable information that could be useful in the goal of opening a official bug report. As said on my side, I can replicate lack of progress bar progress while the command line utility provides some information, X/56 is the number of pages. So there could be progress output in the GUI. But what is your command line output? Is there an error given?

In the absence of additional information, I cannot make this go further.

The goal here would be make you learn how to ask questions, gather enough information for you to open a bug report yourself that would be considered by the developers to fix your discovered issue.

Where does it work as expected? Environments where it works, packages installed there (dispvm template where conversion happens) and templatevm from where the conversion is launched, output of command line utility, screenshots would help.

You seem to say that the conversion fails creating the trusted pdf where the conversion is launched, which is not just a lack of progress bar and that is definitely a bug. That would be useful to know why conversion failed. As said and asked: too big pdf? Not enough memory to finish conversion, conversion killed in between (console would show something) ?

Rename this thread so other people can help you as well, mostly people using that feature on a daily basis.

The goal, if that is a bug, is to have content enough to have relevant github bug reports created for the issue, if issue there are, are fixed.

This is why i gave a pdf example to download and convert, which worked for me from command line, where i witness lack of progress bar progress from debian-11 based aube initiating conversion and where conversion is done on fedora-36-dvm, where command line works as expected.

Replication is key in bug report.

From that alone, we can say that there is no progress, and that the gui should be able to use x/56 pages to draw a progress bar output in gui, which I witness not happening. Was that intended/working/bug? I do not know unless I read the code for both sender/receiver, and that should be a bug report if not already existing on github. Have you checked?

@NicholasTrust did you open an issue?

I have not. No time.