Troubleshooting slow bootup/shutdown?

The startup/shutdown sequence for some reason is now about 10X as long as it was before… (no joke).

I can’t isolate a specific change that might have caused it.

Anyone have some ideas that would lead to this symptom?

When you reach the cryptsetup prompt, press ESC, then insert your decryption password as you’d normally do, just without plymouth. This way you’ll be able to see which processes take the longest.

1 Like

Some good answers here (be cautious modifying files, not recommended):

Otherwise discussion happened in length under:

And then this testing thead for those interested into testing packages before they land in stable repos:

You can try running sudo systemd-analyze blame in dom0, should tell you how long you spend on each step of the boot sequence.


I haven’t noticed this – yet.

One thing you can do, if you haven’t already, is move the startup of your qubes into a script in ~/.config/autostart (or is it autostart-scripts) on dom0. Uncheck the “startup at boot” flag in the qube options for those you move to the script. Yes, you have to wait for them to start up before you can use them, once you’re logged in, but at least you get prompted for your password a lot faster. (As Sven puts it, he can go off and get a cup of tea.)

The only thing I have set to startup at boot is sys-usb. Network, firewall, cacher, my vera-store and vera-keys, and lastly my update canary all start up after I log in. (Update canary is just a minimal template VM I leave running so it will detect that my templates need updates to the OS–cacher seems to interfere with that process otherwise.)

1 Like