Troubleshooting Qubes Desktop - i7 4790k, Maximus Hero VII, GTX 980

I saw these builds:

So I salvaged some parts and I am trying to get qubes installed on desktop with i7 4790k, maximus hero vii board, and GTX 980.

I have enabled vt-d in the bios and I have a display port cable plugged in from the card to my monitor.

When I boot off the USB and select to install qubes, I see the following error repeat a couple times:
[10.644047] dracut-pre-udev[5051]: rpc.idmapd: conf_reinit: open ("(null)", O_RDONLY) failed

Was finally able to catch it as the screen goes black very quickly after it appears.

So searching about the error, I found this discussion:

I am trying to figure out if a newer kernel will help me. Otherwise I could try to include the proprietary nvidia driver in the iso and dom0.

This will be my first time dealing with troubleshooting qubes install, so any tips are appreciated!

1 Like

So I have tried Qubes 4.1 alpha ISO for the newer kernel so far.

After I boot from USB, I select the option “Test Media & Install Qubes” and see a new error different from the previous one above.

[10.291040] dracut-pre-udev[614]: modprobe: ERROR: could not insert 'floppy': No such devices

Not quite sure how to add the proprietary nvidia driver in the iso and dom0 yet, and still trying to figure that out to try it next.

EDIT: A friend has showed me that the GTX 980 is in fact on the supported list for the default qubes nouveau driver. That means the card should be working with Qubes right? I guess I will keep poking at it.

Nvidia GTX 980 Nouveau Codename - NV124 (GM204)

1 Like

Solved! The problem is caused by using display port rather than HDMI.

First I updated the BIOS on the Maximus VII Hero motherboard, and even though that is not the fix it still feels worthy of mentioning.

Then, as I mentioned in the previous post, a friend pointed out that this card should work with the default nouveau drivers in qubes.

So I went looking for common problems with the GTX 980 and discovered that using the display port has caused issues for thousands of users. See link below.

So I grabbed an HDMI cable, plugged it in, ran Qubes install as usual, and that turned out to be the fix! Qubes is running ok now and I did not need to install any special kernel, driver, or use the 4.1 alpha version of qubes. Very thankful my friend pointed that out and helped prevent me from diving in deeper into unnecessary things.

I hope this helps someone out there!

EDIT: For anyone out there that does need to try using proprietary Nvidia drivers with Qubes, see link below.

1 Like