Trouble with installing files in Qubes OS, for example in Feodra

First of all, I would hear your thoughts on using antivirus software in Qubes OS. There are definitely people who say that Linux basically doesn’t need any antivirus software. And that the antivirus software itself can have vulnerabilities, which then represents a greater risk than the malware. Something like that unsettles me.

My real problem, however, is installing files. I admit that I am not a very experienced Linux-User. In the section “Installing and updating software in Dom Us” point 3 says the installation command. What exactly is the “Package_Name”?

For example: I downloaded Comodo antivirus. That thing is called

Is that the Package_Name or the files packed in it?
If I enter the following as in the example:

sudo dnf install Cav-linux_x64.rpm
then I get the message “Can not load RPM file”.

So I did some research on the internet to find out how to install rpm files in Feodra.
I also have no success with the following command:
sudo rpm –i Cav-linux_x64.rpm
The error message is “No such file in Direcotry”. Do I have to give the path here? if yes how?

I would be really grateful for help. Unfortunately I don’t have a real overview of the types of Linux files and commands. Research only leads me to further dead ends. And I am probably making some mistake that is obvious to you and that I do not notice myself.

Many thanks in advance

1 Like


First: i am struggling with the english language. But i’ll try my best. There will probably come a better answer shortly.

Templates are generally used to install software. You could clone an existing one using the Qubes-Manager and install your software there. Then you would create an AppVM (or reconfigure an existing one) to be based on that template.

For your problem regarding the installation process: you problably have to provide the correct directory for that .rpm file or be in the same directory when running ‘sudo dnf install’. For example: ‘cd ~/Downloads’ and then run ‘sudo dnf install filename’.



Dear sgsg,

Thank you for your help. Unfortunately, I was only partially successful.

With “cd ~ documents” I was able to change the path in the terminal. Now there is no longer [user @ fedora-33 ~] but [user @ fedora-33 Documents]

Unfortunately, the two commands still result in the same error messages as mentioned above.

Hi. Please address this as a separate post. Let’s have one topic per thread so we keep the forum tidy :slight_smile:

Do the following: open the file manager, navigate to the folder where the downloaded file is and right-click somewhere on the manager (but not over the file) » Open terminal here. Then you should have a terminal on the right directory.

I’ve recently made a tutorial just on this topic, which I would recommend you to read:

However, the above tutorial is for doing it in a standalone, why may not be what you want. You’ll probably want to do it in a template. But some of the disclaimers in the beginning should apply.


Thank you deeplow,

I’m slowly starting to doubt myself.

If I enter the following:

[user @ feodra-33 Documents] $ sudo rpm -i ~ cav-linux_x64.rpm

then I get now the message “File not found by glob

I’ve read that this can come from badly crafted rpm files. The file is originally downloaded from the manufacturer.


Maybe you mistyped the comand? The tilde does not belong there unless the file is in ‘/home/user/’ - and a slash would still be missing then. If this file you want to install is in ‘/home/user/Documents’ the comand ‘sudo dnf install /home/user/Documents/cav-linux_x64.rpm’ should work.


Thank you sgsg,
I didn’t realize that I would still need the entire path again. Your command worked. However, there are new problems for which I would probably better open a new topic.

Thanks again.

Dear Qubes_Beginner (see? i’m learning a little bit of english diciton)

You are welcome!

The entire path is not needed in this way. You could also have run the command like you first described it ‘sudo dnf install filename.rpm’, if you navigated to the file directory before that. ‘sudo rpm -i filename.rpm’ would have worked also then. Using dnf or any package manager when installing packages locally simply has the advantage that possible dependencies would be listed aswell.


1 Like