Trouble installing QubesOS from USB

Using the ISO in VBox will boot, but obviously errors due to hardware issues.
I flashed the ISO to a USB with rufus quite a few times, in both ISO and DD mode.
The first and third time I tried to use ISO mode, which didn’t work (I have found the reason, DD mode is proper)

The first two attempts were on my old PC, but apparently its hardware isnt supported. Trying on a new HDD on my main PC (flashed in DD mode) I get the following after selecting test media etc.:

(starting from the final “OK” entry)

[  OK  ] Reached target - Basic System.
[   14.476176] dracut-initqueue[1503]: Unknown device "dev//run/install/repo//images/install.img": No such device
[   14.480916] dracut-initqueue[1504]: Unknown device "/sys/": No such device
/dev/sdc:    45caf0e6b2e213590a8cb9353b5e4e52
Fragment sums: 2695f8d1113b95b66ba1c2ec116ec46f3d2631938edc8b43daa7c32f5d3b
Fragment count: 20
Supported ISO: no
Press [Esc] to abort check.
Checking: 004.8%

The media check is complete, the result is: FAIL.

It is not recommended to use this media.
[FAILED] Failed to start checkisomd5@dev-sdc.service - Media check on /dev/sdc.
[   22.670630] dracut-initqueue[1553]: Job for checkisomd5@dev-sdc.service failed because the control process exited with error code.
[   22.670676] dracut-initqueue[1553]: See "systemctl status checkisomd5@dev-sdc.service" and "journalctl -xeu checkisomd5@dev-sdc.service" for details.
[   22.710212] dracut: FATAL: CD check failed!
[   22.710225] dracut: Refusing to continue
[   22.995458] reboot: System halted

I’m completely new to Qubes, I haven’t even gotten it to boot after installing yet.
Currently going to try to repair this usb while I wait for replies.

Update: I have done what I can with the USB, using both diskpart and diskman. I still get the same outcome.

Note: Using Rufus to create the installation medium means that you won’t be able to choose the “Test this media and install Qubes OS” option mentioned in the example below. Instead, choose the “Install Qubes OS” option.

This helped, then I had the problem where VT-d wasn’t enabled. I enabled it, went through installation, but right when installation completed I was having problems. When it would say “Rebooting”, it wouldn’t do anything and instead just sit there, I waited 15 minutes and still nothing so I hard rebooted and removed the USB. After rebooting, I had the config fine, but after that it just stopped after “Started accounts-daemon.service.” Hard rebooted again, and then absolutely nothing, 3 times.

Did you mean that you’ve reached “Initial Setup” stage?

Or did it stop before it?

I booted from the ISO, and got past installation and initial setup. After each, the processes I listed above I assume stopped, but did not error.

Can you make a photo of the messages when boot process stops?

This is all I saw when it stopped, glad I took pictures before I did the hard resets.

Continue because I and only embed one image

What’s your hardware?
Do you have multiple GPUs? Multiple displays?

I have two 1920x1080 monitors, and:
Intel i7-10700k
16GB ram
nvidia RTX 4070 12GB

Try to disconnect the displays from nvidia and connect a single display to your intel GPU (in motherboard port).

Will try this now, likely update in approx. 2 hours.

Since I can’t upload a lot to show the process, here is a video. Uploaded to discord for hosting purposes.


Edit: The final video was after the setup, after I had removed the USB and booted from the HDD qubes was installed on.

Try to enable debug output in the installed Qubes OS to see what happens before the black screen.
Edit the GRUB menu entry like this:

But remove quiet and add these options instead:
For Xen command line (multiboot2 line): loglvl=all guest_loglvl=all vga=,keep
For kernel command line (first module2 line): console=hvc0 earlyprintk=xen

Here is the result:

I think I did see something about forbidden or unauthorized devicebefore starting the recording.

another video

Did you connect your first display to Intel GPU and disconnected the other one?
You can try to switch to another TTY using Ctrl+Alt+F1 - Ctrl+Alt+F12 when you’ve reached the Starting lightdm.service step to check if the system is accessible but only GUI is not showing up.
It seems that it booted up properly but it’s outputting the image on another GPU or port.
I’m not sure if it’ll change anything but can you try to reinstall Qubes OS with only one display connected to your Intel GPU?

Also check the BIOS options and see if there is an option to select the primary GPU. If there is such option then switch it to integrated (intel) GPU.

I looked through bios and changes settings that should have enabled the CPU to output video, but nothing I did would let it, I tried bothe motherboard hdmi and displayport.

So if you disconnect all displays from your nvidia GPU and connect your single display to your intel GPU then you don’t have the video output on display?
With display connected to your intel GPU do you have the video output in BIOS?
With display connected to your intel GPU do you have the video output in Qubes OS installer?