Trouble installing Qubes-R4.1.1 on Dell XPS 15 9560

I followed the instructions given in this page and wrote the ISO to a 16 gb USB stick using dd. The USB stick is now formatted to iso9660 containing the Qubes ISO. I restarted the computer to get into the UEFI menu and chose the USB stick as the top choice for booting into the PC, but it doesn’t boot from the USB stick regardless what I do. Does anyone have a solution for this?


What exactly does it do? Do you get an error? Do you boot into your old distro?

Did you disable secure boot?

If I disable secure boot, the PC gets stuck in GRUB. If secure boot is enabled, I boot into my primary OS.

Could you be a bit more specific?

Welcome to GRUB!

error: one argument expected.
error: missing arguments.

When you ran dd did you select the whole drive (i.e. /dev/sda) or a partition (i.e. /dev/sda1)?

This is the command I ran

sudo dd if=Qubes-R4.1.1-x86_64.iso of=/dev/sda status=progress bs=1048576 conv=fsync

It seems like a generic GRUB error, so it shouldn’t be related to Qubes specifically. Have you tried researching the error messages online?

I don’t have a lot of ideas here, you could try going into your uefi settings, boot > add boot option. Then select the USB drive and move into the UEFI directory and select grub.

You could also try re-flashing the usb, with a newer version perhaps:

Qubes-20221112-kernel-latest-x86_64.iso (These weekly builds are referenced here: QubesOS 4.1 Signed Weekly Builds)

This time try with the following:

$ sudo dd if=Qubes-20221112-kernel-latest-x86_64.iso of=/dev/sda bs=4M status=progress

But make sure that your usb drive is in fact /dev/sda (otherwise change it accordingly)

1 Like

Moved to Hardware issues

I followed your advice and re-flashed the usb with the newer version and used the modified command you provided. I was able to finally install Qubes by disabling secure boot, but I got a few error messages which disappeared quickly under the installation.

This is what the Qubes menu looks like for me after the installation:

This does not look right. Can anyone please guide me in fixing this issue?


If it helped, please select it as accepted answer so it comes up at the top.

Run these in order (in dom0):

$ vm="default-dispvm"
$ sudo qubesctl top.enable qvm.$vm
$ sudo qubesctl state.apply qvm.$vm
$ sudo qubesctl top.disable qvm.$vm

This will create the default disposable vm template. After that, re-run the above but change the value of vm to sys-net, then sys-firewall, then sys-usb.

That will create all the main service qubes.

If you want the Whonix qubes, run the same with sys-whonix and anon-whonix.

You can check out all the available states with:

$ sudo qubesctl top.disabled

Hello, thanks for the reply.

I fixed my problem by choosing the legacy bios over the uefi one and reinstalling the OS.