Trouble installing on Lenovo Ideapad 5 Pro


I ran into trouble trying to install Qubes OS and I can’t find a solution. Really appreciate any help, as due to my threat model, Qubes OS is my only option.

I followed all the instructions on the Qubes website.

When I start up on my bootable USB, I do not see the GUI installer. Instead, I see GRUB. No matter what option I choose, the following happens:

The screen goes black for a few seconds, then black on white text appears. It throws the following errors:

6.5xxx) dracut-pre-udev-(652): wodprobe: ERROR: could not insert ‘floppy’: Device or resource busy

Then it goes through some stuff with a green OK status. Then comes this:

(FAILED) Failed to start udev Wait for Complete Device Intialization.
See ‘systemctl status systemd-udev-settle.service’ for details.

It takes a couple of minutes, and then continues, going through some stuff with a green OK status. Until the following:

(OK) Reached target Basic System

After this, nothing happens. A dash blinks forever, but the device does nothing, even for an hour plus, until I shut it off.

The device is a Lenovo Ideapad 5 Pro 16ARH7 (Rysen 5 6600 HS).

I’m confused as according to the Hardware Compatability List this device should work. I can boot into Linux Mint and Tails OS on the same device. On Mint, the keyboard does not work well however.

I already tried installing from Windows (with Rufus DD mode), as well as from Linux CLI, with different USB sticks, but it changed nothing.

My experience with CLI and Linux is limited, so really appreciate any help!

Most likely this issue.

You can probably solve this by adding x2apic=false to the grub item.

To do this, when grub shows up, navigate to your desired installation option ( “install with kernel latest”, e.g.). Then, press e key to edit that option. Scroll down with arrow keys, and find the line beginning with “multiboot2”, and add x2apic=false to the end of that line.

Thank you very much!

That got me past this hurdle, but I’m running into new issues.

I was able to access the GUI installer, though the touchpad did not work. I was able to go through the install process using arrow keys and keyboard.

After hittig ‘reboot’, everything seemed to work fine, but after taking a long time with the grey bar filling up slowly, eventually hitting the end of the bar, nothing happened. After leaving the computer in this state for an hour, the GUI disappeared and the device showed this message:

(1.714136) dracut-cmdline(272): Warning: USB in dom0 is not restricted. Consider rd.qubes.hide_all_usb or usbcore.authorized_default=0

Then nothing happened anymore until I shut off the device.

To be clear, the OS never even prompted me to decrypt the drive.

When I ran “test this media and install Qubes OS” before that, it gave a bunch of errors:

dracut-initqueue(1209): mount /run/install/repo: WARNING: device write-protected, mounted read-only

dracut-initqueue(1194): /lib/ line 71: shift Z: shift count out of range
/dev/sda: some code
Fragment count: 20
Supported ISO: no

Checking 004.8%

The media check is complete, the result is: FAIL.

It is not recommended to use this media.
dracut-initqueue (1311): Job for checkisomd50-dev-sda.service failed because the control process exited with error code.
dracut-initqueue(1311): See ‘systemctl status check checkisomd50-dev-sda.service’ and ‘journalctl -xe’ for details.
dracut FATAL: CD check failed!
dracut: Refusing to continue
systemd-shutdown(1): Waiting for process rngd

I appreciate any help!


I now added the option x2apic=false at startup again (not only while installing), and installed from a freshly flashed new USB drive from a different manufacturer. I was able to progress to the Qubes desktop, so it actually started up normally.

But, when I configured the OS, it said that Fedora, Debian and Whonix templates were not available. I don’t know what this means.

And the other issue I have now is that the touchpad does not work. I can open up a terminal however and enter code there.


It is fixed now.

The steps I undertook (don’t know which worked).

  1. Implement answer of augsch, while installing and starting up.

  2. Nuking the SSD I tried to install Qubes OS on before installing (from another live OS).

  3. Not selecting “install from the latest Kernel”, but rather “install Qubes OS”.

  4. Using a different USB drive flashed on RUFUS.

I can’t get the Wi-Fi to work, but will make a seperate post for that as it is a seperate issue (post-install).

Thanks for the help!

1 Like