Trouble installing Mirage Firewall

Check out Mirage Firewall, I have tried to get it to work but failed, but you might have more success, let me know if you do cause I would like to know how to get it to work

I have experience installing Mirage both via source and pre-built. What issues are you encountering?

Also, given how long it has been since the last update (Jul. 2020), I’m a little bit uneasy about its current state. But maybe Microkernels don’t really need updates.

Whenever I would build from the source, i would be asked to get opam repositories, everytime I would it would just get an error and crash, the pre-built worked but for some reason it ended up being about a 10gb qube. The opam repositories would crash and say that opam repositories cant be found etc. I dont have the specific error code cause it was a while ago.

Would be good to know about Microkernels updates

Did you check the firewall configuration of the VM you’re using to build it? It sounds like you have a firewall or connectivity issue.

You should try following the instructions for the pre-built microkernel, line by line, since it should work perfectly. You might have generated a 10gb VM by mistyping something, so be extra cautious.

thanks ill try again, but I might wait to see what people say about Microkernels updates cause that could cause a security flaw

@deeplow can you spit this topic from this (i think i used deeplow too much)

I split the topic–thanks for reminding me


i don’t know that trust level 3 user can do that
edit: that outdated, now he leader

I haven’t been participating lately so I haven’t had the chance to use my mod functions.

wait, i can modify this thread ?!?

No, I meant that I haven’t had an opportunity to use my newly-granted moderator abilities since I haven’t been active lately.

Summary speaking of the devil :>

mistook the general devel of mirage with qubes mirage fw package… sorri

1 Like