Trouble getting microphone working


I have problem with getting microphone working. I’m on notebook with minijack combo 3.5 mm input and 4 pin and adapter to 3 pin jack speakers and 3 pin microphone.
Even when I don’t use adapter I mean - I use audio monitor (HDMI) as output and microphone 3,5 as input. Then I set it in pavucontrol as input device. Still there’s no reaction.

It’s funny, because on another laptop with ordinary 3 pin microphone input and fedora 32 onboard, microphone doesn’t work too.

I checked if hardware is damaged, but on Windows it worked…

I guess I just don’t know how to configure it properly, I tried to find anything in ArchWiki or other forums but without success.

I’m completely run out of ideas, please help me :pray: :slight_smile:

(@BBro, I’ve moved this onto it’s own thread since it seems to be a different issue)

1 Like

Thanks for moving, in future I’ll correct

So yes, I tried to set port in output device and it’s set properly to “Headphones” or HDMI, depending on if I use the microphone adapter.

In Input devices microphone appears normally. Device port is called “Microphone”. I see the bar at the bottom with microphone recording status, there’s silence.

When I play some music in some AppVM, I see that playback is used as microphone input in pavucontrol settings. This’s strange a bit.

1 Like

After deeper searching forums It seems to be a hardware issue.
Hah, never use laptops until they are fully supported by Linux kernel, and everything is on one motherboard :wink: