Tried everything, install won't work if it installs at all

OK…this is complex.

I downloaded and dd’ed to a thumb drive the 4.1 release.

My computer boots off the thumb drive. The problem is the installer can’t see my SSD drives, nor can it see an actual rotating platter hard drive.

It CAN see other thumb drives, however. So I installed to the thumb drive. (This takes between 2.5 and 3 hours). It takes half an hour or so to boot off the thumb drive (and I’m not even sure that works more than once…I don’t want to go through setup…not yet, so I have to shut the machine off (there’s no graceful power off button on the initial screen, at least not that I can see.)

I tried dd’ing the thumb drive to an SSD (this was the workaround suggested somewhere), but the computer doesn’t consider the SSD a valid boot medium. OK, maybe something about dd-ing a thumb drive to an SSD makes it a bad SSD? Oh, by the way the DD takes over two hours, to copy 60GB to the SSD.

I went to another box and successfully installed to an SSD there (THAT was a lot faster). With the caveat that THAT machine has unsupported hardware in it (It’s missing something or other than Qubes needs to do proper virtualization). THAT SSD will not boot on THIS machine, either.

My normal want-to-supplant OS is xubuntu 20.4, and IT is installed on an SSD; no trouble there. Never any damn HINT of trouble with SSDs or hard drives until I tried installing Qubes.

I’m at wits end; I’m stymied at every turn.

I forgot to write down my bios/motherboard information. I’ll post this and be back with that…I shall have to reboot.

EDIT: The only things I could find don’t look useful.

American Megatrends
297X-Gaming G1 WIFI-BK
Bios Version F8 09/19/2015

I don’t know if the Bios ID would be useful but I suspect it’s a serial number so I won’t post it unless it’s absolutely necessary .

Maybe try to change RAID to AHCI in BIOS if you have RAID enabled.

I do not have RAID enabled…that was something I did check a couple of days ago.

You can try this one:

Also this seems to be a problem with Fedora and not because of Qubes specifically.

OK, will try that next.

I went back into the boot mode and verified I don’t have RAID enabled. There are three options, IDE, AHCI, and RAID. I tried all three (why not)? You can also disable integrated RAID, and I tried that as well. And now I’m back. Let’s see what happens with this.

If it won’t work then you can just add UEFI boot entry with efibootmgr from the link in my first post for your Qubes installed on another PC from here:

I could find no way in my BIOS to shut off the F12 menu. Will have to do some research. (EDIT: when I look for American Megatrends disable boot menu, I get a bunch of hits on disabling the American Megatrends screen at the beginning of the boot process…useless.)

Unfortunately I couldn’t make heads or tails of what to do with that UEFI entry thing. You’re basically speaking Martian. It looks like I’d have to set it up after booting into the disk I can’t boot from? Otherwise I have no way of knowing its name.

And that doesn’t seem to address the issue with the installer at all.

Another dive through the BIOS settings…still can find no way to disable F12.

I’ve been at this for three days now.

Download and flash SystemRescue ISO on your USB drive:
Boot from it and in terminal execute this command, assuming that sda is your SSD on which you installed Qubes on another PC and 1 is EFI partition on this disk:
efibootmgr -v -c -u -L Qubes -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1
Or you can do it from Qubes installer ISO in Rescue mode or in installer if you switch tty from GUI to terminal with Ctrl+Alt+F2 or try different F1-F7 keys.

I can only guess that it’s sda as it never booted off that drive in the first place…and the letter assignments seem pretty random. However, when going into Qubes I expect to have just the one drive. (I can guarantee you it’s NOT sda from within ubuntu.)

Anyhow, besides that, if I have to go through what you just described every time I switch OSes…I’ll have to decide if it’s worth the trouble.

You can check if it’s the right drive/partition with this command:
fdisk -l
If you don’t see your SSD in terminal from Qubes installer ISO then try the SystemRescue ISO.

It’s not about switching OSes but about removing the drive from your PC.
At the link in my first post there is a fix to this problem:

That would pretty much be every time I go back and forth to the Qubes OS.

My boot menu lists everything as UEFI (no modifiers) as well as other listings, and so I can’t tell them apart. I have to physically remove the drives I don’t want to be sure of booting where I want. (Right now, I have two physical drives on this system, one a blank drive I couldn’t see in the installer, the other ubuntu, and there are five entries in my F12 menu; two pairs of indistinguishable ones and “ubuntu” which never comes first. Since one of the two disks is unbootable it’s fine in this configuration but I effectively have no control over what boots if there are two bootable disks in the system.

I also admit I have no idea why your username (or mine, presumably) is part of the procedure!

Then you can follow the steps that I quoted in my last post.

It’s just an example EFI entry name that you will see in EFI boot menu like ubuntu. You can name it Qubes for example:

efibootmgr -v -c -u -L Qubes -l /EFI/BOOT/bootx.64efi -d /dev/sda -p 1

The other issue (which may be a non-issue for all I know) is that the drive you’re telling me to boot from was built on another box, on another motherboard with unsupported hardware (and missing hardware that Qubes OS needs). God alone knows whether it would even be a proper install or whether the installer just left out stuff for hardware that wasn’t on that motherboard but IS on this motherboard.

This all goes back to, I need to be able to INSTALL on this system or I won’t trust it to be a good install. Getting it to boot afterwards is step 2.

I’d suggest you to download Fedora 32 installer and try to install it on your drive. If you can’t see drives in installer again then it’d be faster to ask about this problem on or search for the same problem there. There are more chances that you’ll get help there if it’s fedora-related issue.

OK, so I did two things…went into the BIOS and removed everything from the boot order that wasnt specifically labeled Ubuntu.

I then powered off, unplugged the Ubuntu drive, plugged in the SSD which I copied from the thumb drive where I installed on the target system (so at least it wasn’t bitching at me about unsupported hardware during the install–a most disquieting thing).

I then plugged in the install thumbdrive.

The system booted off that drive even though it’s NOT part of the boot sequence in the BIOS.

Getting into the terminal, I did an lsblk and it showed me two things…a bunch of stuff hanging off of “loop” and sda. But pulling the installation thumbdrive out, established that sda was the thumb drive.

fdisk -l returned similar results, sda and references to loop.

In other words the SSD is invisible even to the terminal.

It looks like your last suggestion about Fedora is the way to proceed.


[Rant: It looks like the main reason to have all of these different distros is so that someone can arbitrarily select one that won’t work on my system. Honestly (given they both work…which is not true, but roll with me here) what cosmically meaningful difference is there between Fedora and Debian? What makes one preferable over the other, so much so that you’ll develop on it even though it doesn’t properly support a lot of hardware out there? Now when you get to desktop environments, it’s a different story but apparently you can mix and match those. For example I actually use xfce, on my debian release, and apparently Qubes uses it too, if only I could get far enough to see that.]

There are multiple different reasons for every distribution.
For example debian vs fedora:
Debian was released earlier and it’s free and developed by community.
Red Hat Linux (Fedora branched from it later) was released later and was commercial and developed by Red Hat company.

If nothing else at least the Fedora installer is gratifyingly small (a mere 1.9 GB…yes, that should be read with a sarcastic tone) so it might only take three hours to download it.

OK, you explained the history of where debian and RH came from, but that doesn’t explain why an end user today would want to pick one over the other.

And yet I see people wanting to change distros on boxes that came with pre-installed Linux of one kind or another. (“Nice system but I want to run Arch on it.”) Why? Don’t they risk tripping over something that won’t work on that box?