TP-Link WN725N and Android Tethering, QubesOS Networking

How Is Going Guys, I’m New Here And the same for qubes, so please forgive my limited knowledge.
Firstly: i installed Qubes 4.1.1 recently and i had issues with my wifi-usb adapter and my android phone.
My Wifi-usb adapter is: TP-Link WN725N, and it’s working properly with both windows and linux i tried it on windows 10/11 and also on Kodachi Linux, Ubuntu, Kali Linux and many others and it was working properly and connects to wifi without any problem, and it didn’t need any drivers cuz i believe from my limited knowledge in linux it’s based in the linux kernal it self, but the problem when it comes to qubes is: first time i installed qubes i selected that the sys-net handles both networking and usb because i have a usb mice and keyboard on my PC so i didn’t create a sys-usb and used sys-net for usb and networking to capture my usb-wifi adapter and use it for wifi but when i started qubes the sys-net didn’t capture my wifi adapter but if i typed “lsusb” in dom0 terminal it shows my usb-wifi adapter so i don’t know what is the problem, but i searched online and somehow it appeared to be in the driver but i used to not use an adapter for such a thing on any linux, and also another solution told me to create a sys-usb so i did, the first time obviously i bricked my usb keyboard and mice but after that i configured it to allow the use of my usb mice and keyboard for dom0 and it worked well and showed my usb-wifi adapter in the devices icon and when i attached my usb-wifi to sys-net there was no problem and it showed the wifi AP around me but when i try to connect it just says disconnected before even show me the window to write the password of the wifi, i tried to grab some drivers from the internet like: GitHub - ilnanny/TL-WN725N-TP-Link-Debian: Driver for wireless usb adaptor " TL-WN725N-TP-Link-2" for Debian -Ubuntu-linuxMint and derivates , and: GitHub - lwfinger/rtl8188eu: Repository for stand-alone RTL8188EU driver., but nothing worked also cuz i use fedora as my default template for qubes, i also tried to copy drivers from ubuntu and use it in qubes but i think i missed up with them and it didn’t work, also tried to copy driver from windows ( the .inf and .sys files ) and use ndiswrapper to get it to work on qubes, but it’s not installable on fedora 36, it’s been three weeks until now and i couldn’t get it to work, and tell me if you need any outputs.
My Other problem is with: my Samsung Galaxy A23 Android 13 device i want to use it with qubes to interact with files in it and to use as a webcam ( maybe use iriun webcam or any other thing that works on qubes maybe VDO.NINJA ) and also to use usb tethering. Firstly in qubes it didn’t catch it in the devices icon but on dom0 appeared in “lsusb”, and after i created the sys-usb as above it appeared in the devices icon but when i tried to attach it to any AppVM ( like sys-net to use usb tethering or to personal qube to use files in it ) it just gave me an attach error, and here is a photo for the error:
Screenshot from 2023-02-12 14-30-29 edited

Please advice me with everything you can, and i can get you any output you want, and please forgive my knowledge and my writing cuz I’m frustrated with my situation now, and if there is no solutions, Please suggest me a good system to implement that would be sort of similar to Qubes OS.

the closest you could do is use kvm/qemu on any other distro, and spin up a vm, and use it, then destroy the vm and repeat the process. QEMU is lighting in comparison to xen. Best solution possible tho is to have 10 or more devices, (different devices with different hardware if possible" and use each separate device for one small task only.

As always, the solution depends on the exact threat that you are trying to mitigate. For example, not even being online is the ultimate way to have online security.

But yeah, people read all that and internally roll their eyes… oah, another user who has probs with hardware working in Qubes? Take a number, there are a million people in from of you. I had wireless networking woes, and went with a lan cable- a solid solution. It can be an uphill battle, trying to fit hardware to Qubes. Then the next update could break it all again. Simplicity is your friend…physically change or eliminate hardware that is causing you probs- try to stick with hardware that works out of the box, or its not worth the time/effort/extra security risk of using "bad"hardware. In qubes, most hardware is “bad”.

Answer to your reply-------
depends on your exact goals. Qubes is a pain with hardware, but in general terms, is first place. TAILS (you run it off a thumb drive" has got to be in 2nd place. Using any machine, doing as little as possible on each machine and then destroying the session and starting again- (like i explained in first reply) can sort of mimick qubes but is not as secure.

Answer to 2nd reply-------
depends on situation/goals, what you are trying to accomplish. Sticking with the pains of Qubes seperates the boys from the men, it is a rite of passage that most qubes ppl go through, you know, coming to terms with how horrid hardware support and performance is. Nevertheless, Qubes shines in some areas, for people who stick with it through the headaches.

1 Like

Yeah these are good solutions, but is there nothing to do with Qubes in my situation now ? and using Ethernet LAN cable won’t work for me because the AP i want to connect to doesn’t even have an Ethernet Port. is there nothing really to do in my situation ? no solutions ?


If Qubes won’t work for then, Recommend me some great OSs/Linux Distros that is pretty good and maybe you tried them.

Alright Thanks Buddy for the reply, i really appreciate it, looks like i’m gonna use either Kodachi or Tails, i hope it goes well. Thanks