Touchpad stopped working

Yesterday I updated my qubes (dom0 and templates). Before shutting down touchpad was working. After rebooting laptop was behaving abnormally slow and keyboard was not working at luks decryption page (surprisingly CAPS Lock is working there but no other key).

After several reboots later I somehow gained access using Advanced qubes boot options and entering luks password at terminal but now touchpad is not working/detecting.

After one reboot touchpad miraculously worked but after another same issue is happening.

While checking system tools > settings manager > mouse and touchpad the touchpad name is missing from the drop down ( it showed something before the updates).

Updater was failing every time with error about cache something so I tried command line as follows:-

1. sudo qubesctl --show-output state.sls update.qubes-dom0

2. sudo qubesctl --show-output --skip-dom0 --templates state.sls update.qubes-vm

This updated 4 templates and I had to update remaining using the update option on Qube Manager. Now boot time has also increased from 2-3 s to 5-10+.

Currently I make do with mouse and hope for a quick resolution of this issue whatever it maybe.

Have you checked the forum about the same retcode as I have?

No retcodes in this case yet. I will keep record of future errors.

Keyboard issue is still happening with Qubes OS default boot option but while trying with Advanced options ( Qubes with xen hypervisor ) and choosing the first option listed there, I have got both keyboard and touchpad working.

I have no idea how it got working again, maybe issue with default boot or some bug in my firmware.

Do tell what information is required from my end. I will be happy to provide whatever information is needed for the full investigation of this issue.

Just one more thing I observed, normally the cancel buttion ( :red_circle: ) appears in LHS of prompt and Yes button ( :green_circle: ) appears in RHS but in my system they sometime swap places and get reverted after reboot. Is this normal behaviour? Has it happened with anyone yet or have I messed up my system in some delicate way?

P.s- If anyone can provide their dmesg and journalctl logs of any Qubes certified hardware it would be of great help.

@Sven ^^

I got nothing for your main issue. Sorry.

At least in Qt apps (e.g. many of the Qubes OS specific dialogs / Qube Manager) this is style driven. So if you have for example recently installed qt5-qtstyleplugins and then set the style to gtk2 to enable dark mode or your theme of choice … that has very likely revered the order of the buttons to conform to the Gnome/Gtk way of doing things.

Keyboard and touchpad are working in main boot idk how. I didn’t do anything for that.

Also on swap issue I havn’t done any theme tweak.

Guess I will take all logs from this system and fresh install qubes, will be a headache but might help in long shot.