Touch screen scrolling for browsers

I notice that touch screen scrolling does not work for the Firefox browsers in all of the Vm. When we try to scroll as it just select text. I run into this situation with Linux Mint as well but when I apply the changes in the following steps, lit works.

  1. open about:config in firefox to set dom.w3c_touch_events.enabled=1 (default is 2).
  2. edit /etc/security/pam_env.conf and add MOZ_USE_XINPUT2 DEFAULT=1
  3. reboot and restart firefox

Link here

I perform these steps and test them in my linux mint standalone vm as well as a debian base standalone vm but I do not notce any difference in results. After reboot, I did see that the modifications survive but still no touch scrolling.
My real purpose is to get touch screen scrolling to use on Brave browser and other Chromium browsers that I use daily. These browsers get touch screen scrolling out of the box in Linux Mint without any modification though. Here in Qubes Os things are a bit different. Right now none of the browser have this working for me. Thanks for any help offer

1 Like

this is awesome, thanks for sharing, will test this later since i have been looking into this