Touch screen no longer working after reinstall

I recently reinstalled Qubes on my X1 Carbon Thinkpad. I installed the latest stable version. The previous install was probably the same version but some updates behind. The touch screen was working on the previous install. I don’t remember if I had to do something special to get it working before. Anyway it’s not working at all now.

Things I’ve tried:

  • updated all the VMs and dom0 and later updated from the testing repo
  • edited some /etc/qubes-rpc/policy files to allow dom0
  • assigning USB controllers to a VM vs. leaving them for dom0.

Is there anything else I should try?

Problem solved! Hallelujah!

I reinstalled again and made a sys-usb this time. The touch screen only works when it’s assigned to sys-usb. Apparently it was not working previously because I was using disp-sys-net for the USB controllers. I also tried assigning the touch screen controller alone to sys-usb and that did not work. So the touch screen controller needs to be grouped with one or both of the other USB controllers to work.