Tor Browser not installable in whonix-ws-16

I"m using Qubes OS 4.1 and have barely set anything customized up yet. It’s in its default settings mostly.

This is how my qube-manager looks like:

Now to my problem: whenever I try to install the tor browser in whonix workstation qube I’m unable to install tor browser with the following message:

INFO: Downloading Tor Browser...
INFO: Downloading...:
INFO: CURL_OUT_FILE: /var/cache/tb-binary/.cache/tb/files/tor-browser-linux64-11.5_en-US.tar.xz
/usr/libexec/helper-scripts/curl-prgrs: line 269: 11187 Killed                  ( set +e; $CURL --trace-ascii "$tracefile" -s "$@"; curl_exit_code="$?"; echo "$curl_exit_code" > "$statusfile"; echo >> "$tracefile"; sync )

ERROR: Failed to download:

Possible reasons:

- The download server is down.
- File size exceeded (endless data attack triggered).
- Tor Browser Downloader (by Whonix developers) has been broken due to upstream changes.


- Try again later. If the error persists it probably won't solve itself before the next update.
- Check News:
- Manually update:

(Debugging information: curl_status_message: [81] - [curl-scripts curl-prgs (not curl!) reports: Endless data attack triggered.])

I’m also interested in a solution to this problem. Whenever I run update-torbrowser --onion as root in my whonix-ws template I receive a similar error message sometime during the download. It has been happening routinely for a while now. However, if I keep attempting to update the tor browser in this way, eventually I’m able to successfully complete the update.

I just made an account to say that Im having the same problem, but Im using Whonix in Virtualbox with Parrot, so I think there is something bad with the last update of Tor Browser. I receive the error 139:

"ERROR: Tor Browser ended with non-zero (error) exit code!
Tor Browser was started with:
/home/user/.tb/tor-browser/Browser/start-tor-browser --verbose --allow-remote .
Tor Browser exited with code: 139

Exactly this. Like is 17h ago and is happening in two differents OS, Qubes and Parrot with Virtualbox and Whonix, I think there is something bad with the last version of Tor. Hope this can be solved soon!

1 Like