Tools installation on Windows 7 64bit

Hi, I’m trying to install the drivers in windows 7. I followed the procedure described in the official documentation. Each time it restarts with the recovery procedure.
I looked around and on the microsoft forum they say to use these commands:

bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON

But dont work. Each time it restarts and goes into recovery mode.
Thank you.

QUBES version: 4.1
Windows 7 64bit ultimate SP1

Some time ago i tried to install windows 7 and has some problem. It may be solved by installing update pack before installing Qubes Windows Tools, but I remember random blue screens, but I may forgot the right result. May be blue screens shows only in my buggy Windows 7 build. I have used Windows 7 with QWT for some time, but now I use only Windows 10, because I need specific apps.

Direct link, if you don’t want to read or can’t use a translator:

You should never allow unrestricted network access to any Windows, because it may contain spyware.

Hello and welcome to Qubes (forum and world). What drivers and what procedure from whose and which official documentation?

Hello, thanks to you for the support! Qubes is a fantastic distribution!

Basically the procedure, if I have not misunderstood, consists in deactivating the driver signature check, restarting with the driver cdrom and installing the Qubes drivers. The only anomaly I found is that when you restart the Qube actually turns off, but I don’t think it matters so much to the operating system. Each time the windows recovery starts and brings everything back. The windows version is unlicensed, but I don’t know if it affects this part (I’ll get it if it works above). I’ve been looking if there is another way to disable this driver verification system, but even using microsoft site instructions it fails.

The deactivation setting operations are done by cmd as administrator. the reboot I do it with shutdown /h always from cmd.

I always keep the operating system and drivers (qubes-dom0-update qubes-windows-tools) updated, I always update them as soon as they are present.

Thank you!

Indeed is. the more, the more you use it.

Which version of QWT you are using?

The latest version obtained from the update: 4.1.68-1

That’s good. It is still unclear to me which drivers exactly you are trying to install, by name. Those offered by QWT? All of them?

Yes, I install the complete package and every time the windows are restored after reboot.

Good Will you try not to install network drivers and then restart? Also, do not restart when offered… Say no and complete installation, then shutdown, then start.

i found this error in the recovery window of windows.: xenbus.sys

Please confirm that you uninstalled all QWT you previously tried to install, and that you tried the method from my last message. I am almost sure it’s about that. Also, which version of xenbus.sys is reported to be corrupted 9but after you try previous).

is a virgin version of windows 7 (en_windows_7_ultimate_x64_dvd.iso). Each time it restores, it cancels all files installed since the last check then and all software.

I have also installed a new qube with windows 7.

This is the driver version:

Also with this fail:


I have downloaded also the driver from here (for test):

The network work, the xenbus not. Same problem of QWT.

The problem is the xenbus.

I found this:

" Uninstall KB932596 , KB938979 , KB938194 and KB941649 updates from “Installed Updates” in “Programs and Features”, and never install them again. Best still, hide the updates from viewing and accidental install in Windows Update. After uninstalling and rebooting the computer, add the DDISABLE_INTEGRITY_CHECKS option and restart to disable integrity checks again. This method probably won’t work with the release of SP1, which incorporated all these changes."

Could you post the Windows 7 instructions, also did you install a gpu-vm first?