Thinkpad x240 restarts after disk encryption password entered

My Qubes OS is restarting after first password screen. Lenovo Thinkpad X240

Booted this laptop last a few weeks ago, not sure if I recall having USB connection issues I was trying to fix. Maybe I disconnected a USB drive I shouldn’t have?

Any help much appreciated!

I’ve renamed this to “Thinkpad x240 restarts after disk encryption password entered” for clarity. Let me know if this correctly reflects your issue.

It does, thanks

1 Like

Hello @steve,

You bring up “USB connection issues”, but I do not understand its relevance to your Qubes OS boot problem. Are you booting Qubes OS from a USB? Using a USB stick during the boot process, such as with a detached /boot or LUKS header? Clarity on this may make diagnosing the problem much easier.

If at all possible, posting any logs, error messages, or other potentially relevant information here will probably help. Pressing ESC when presented with the Plymouth boot screen (the “Q” logo with the password prompt) will allow you to see what is going on behind the scenes. Also, if you are able to access the Dracut emergency shell at any point during boot, providing some of the output from journalctl -xb may prove to be useful.


Thanks for the reply!

I have Qubes installed alone on my SSD. I mean to say I was troubleshooting a USB device issue and was connecting/disconnecting USB options to a certain VM. I was speculating maybe I disconnected something key to Qubes booting successfully.

After password entry, no error messages display. The computer simply reboots back into Qubes. I booted another OS from USB (Tails OS), which operates with no issue.

After pressing ESC, what should I do? I see text at the bottom “press c for command line,” but when entering journalctl -xb command it says “cannot find command.” So I assume this is not Dracut shell?

Thanks again for any assistance as I have important files backed up on this drive!

1 Like

Thanks for clarifying, @steve. It seems I was not clear myself however, so apologies for the confusion. By the “Plymouth boot screen” I mean the password prompt screen that comes after the GRUB boot screen. Given the “c for command line” message you see at the bottom, I suspect you are looking at the GRUB boot screen, which looks like this (source):

GRUB boot screen display

So, the command-line terminal you were entering into was the GRUB minimal shell, which has very few tools embedded in it. journalctl is not one of them, which is why you got the message you did. You are correct that this is not the Dracut emergency shell.

After GRUB boots, what follows is the Plymouth boot screen, which is a graphical display that provides eye-candy while the boot messages zip by behind it. That’s what the splash quiet kernel parameters enable on systems that use Plymouth. It looks like this (source):

Pressing ESC on this screen toggles these parameters and shows the kernel messages happening behind the scenes. That is what matters here, and that is where you will meet the Dracut emergency shell (if it shows up at all).

Best of luck,

Understood, thanks!

Pressing ESC on this screen opens a command line but asks for my password. Pressing ESC again brings back the GUI.

When I enter the password on this screen, I am not able to input anything else before some lines of text do show up. These are the last two messages before restart:

Kernal panic - not syncing: fatal exception
Kernal offset: disabled

If unable to access Dracut shell, would the GRUB shell have any useful commands?

Thanks again

1 Like

Now that we have identified that it is a kernel panic, that information may help point toward a solution. I have been reviewing some of the forum posts mentioning “kernel panic” and see a variety of possible explanations.

Since it sounds like this is not a fresh install you’re having trouble with, maybe it has to do with a dom0 update breaking boot. Before this problem started, do you recall applying any updates to dom0? If so, and if you have a backup from before the updates to which you can restore, that may fix it, as was suggested here. Alternatively, it was suggested that it could be a corrupted initramfs issue, in which case booting from a rescue disk or live system, chrooting into the system, and recreating initramfs might also fix it, which can be done with the dracut --force command.

Without further information however, it is not clear whether either address the problem. I can say that I have no reason to suspect that this has anything to do with your USB (dis)connection activities as of yet, though.

For now, I recommend you search around in this forum, on mailing lists (such as the [qubes-users] mailing list), and elsewhere online for what others have said regarding the kernel panic error you are getting, since some of the descriptions may sound familiar to your experiences. I will do so as well, when I have the time, but for now the best I can recommend are those two ideas above, that it may be a dom0 update error for which a backup restoration can fix or it may be a corrupted initramfs for which its regeneration may be the solution.

Wish I could be of more help,

P. S. It seems like you are not the only one with this problem, though unfortunately that thread received no further replies. So while not a solution, at least it confirms that you are not the only one experiencing this problem. This thread seems similar to your problem as well (and it has replies), so maybe it will help you.

P. P. S. This forum thread may also prove to be instructive if the problem is with a failed dom0 update breaking initramfs and resulting in a kernel panic.


I see you are using the email method here, so you probably do not see the edits to my posts. In that case, I will repeat what I edited into the post above here:

P. P. S. This forum thread may also prove to be instructive if the problem is with a failed dom0 update breaking initramfs and resulting in a kernel panic.


That’s very helpful! I will go over these threads when able and post any results.

And yes, I distinctly recall updating dom0 last boot, so that’s the culprit for now.

Will follow up on these threads, thanks so much!


Glad to help, @steve. If I find anything else that may be relevant to your problem, I will reply here. Of course, if you encounter any further problems or errors and you are unsure about how to proceed, just reply to this thread and maybe we can help each other figure out what the problem might be.

Best regards,