ThinkPad T14 (gen. 5) failes net qubes and freezes at systemd-hostnamed

I am running Qubes OS 4.2 for some time on my Intel Nuc. Today I tried to install it on new ThinkPad T14. During installation I got an Unable to reset PCI device.

The boot process now failes for sys-whonix, sys-net and sys-firewall and the system freezes at starting systemd-hostnamed.

achrinz reported for Qubes OS on T14 Gen 1 that he has to “unselect” the ethernet controller.

I think I need some hints on to archive this to test if this is still working for Gen 5.

I would be very happy if their’s some to path me through this?

You can disable qubes autostart to boot in dom0:

And then in dom0 you can open sys-net Settings → Devices tab and remove the Ethernet controller from the list of PCI devices attached to this qube.

Thank you, @apparatus! :pray:

Editing the GRUB, disables the qubes. I can not see any FAILED entries any more. But the boot process still freezes with:

Starting plymouth-quit-wait.service - Hold until boot process finishes up...

How to debug this?

Try to install Qubes OS with kernel-latest. Maybe there are no drivers for your GPU in the older kernel.

@apparatus : To give you a quick feedback: Running kernel-latest immediately boots into the GUI. It looks like setting no strict reset one of the network interfaces fixes the crash of sys-net.

More details will follow after checking and looking around a bit.

Again: Thanks a lot!

Last issue I found (is unfortunately a big one): I can no get the Wi-Fi network to work. sys-net does not find a Wi-Fi device.

What’s the output of this command in sys-net?

sudo lspci -nn

Do you see your wireless controller there?
What [VID:PID] does it have? Check the end of the line.

lspci is not installed in sys-net. But in dom0 I can see an “Ethernet controller” and a “Network controller”. So I guess one is the Wi-Fi.

What is the “Network controller” [VID:PID] in lspci -nn output in dom0?
Do you have “Network controller” in the right column in the sys-net Settings → Devices tab?

Intel Corporation Device [8086:7e40] and yes. It is in the right tab of sys-net.

According to How to troubleshoot “no wifi” in qubes I should try Fedora for sys-net. If there’s no better idea I will try this tomorrow.

Debian firmware package seems to be missing AX211 firmware and you need to download and copy the firmware file to the debian template manually (or copy the firmware file from fedora template it it’s present there). You can try Fedora template since it has newer firmware and maybe AX211 firmware is present there.