The differences between Qube VM

Please help me with some questions below:

By default, Qubes OS gives us 4 types of VM, they are:
disposable, domain, service and template.
What is the difference between the 4 ?

I know that, Qubes separates between,
VM to install the software, and VM to run the software,
so is it correct, if we conclude that,
template VM is the VM we install the software, and
disposable VM is the VM we run the software ?

When I create new qube, from the existing template,
why it is categorized as service ?
I thought it will be categorized as disposable.

If we create VM from existing template, and then update the software in the new created VM, will the update exist in the template ?

What is netVM, appVM and proxyVM ?
How do we know if a VM is netVM, appVM, or proxyVM ?

if we want to setup VPN, in which type of VM we have to set it up ?
Disposable, domain, service, template, or in dom0 ?

When I open the VPN connection setup, in the Internet connection Icon, it direct me to VM service sys-net, is it the only place to setup VPN ?

You could answer most of these questions just by reading the glossary: ,
and the introduction to Qubes:

That will help you understand for yourself, and clear up some of your

Once you’re read them , if you still have problems, ask again.

1 Like

Okay, I am sorry, I will read first

No apology needed. It can be difficult to know where to start in the
If anything doesn’t make sense afterwards, don’t hesitate to ask.

I have read the documents,
and found answer for most of my questions above.
Thank you.

But I could not find answer for a question,

I have read this doc
and setup VPN as described in the doc. It works properly.

A new netVM sys-vpn is created, on top of sys-firewall,
and I use it to provide internet access for fedora dvm.
It works properly.

But I could not login into some website, especially Google.
I use the same vpn, on other laptop, with other OS, to login to the same websites, and it works.
Did I miss something on my VPN setup ? which result on login failure ?

And after I reboot my laptop, the VPN installation gone,
so I have to re-install and re-setup after each reboot.
I have tried to install other software in other VM,
and the same thing happen, it gone after reboot.
Why net VM behave like disposable VM ?

I have tried to read some documents,
but could not find any solution.

Please kindly help me for the 2 issues,
or maybe suggest me some documents.

I think this could be better addressed in a separate thread. But in general, the VPN documentation you followed is not user friendly, unfortunately. There is even a discussion about that:

There are better alternatives that I would try before trying to debug the google/restart problem. See the following discussion as an entry point (or look for VPN on the forum)

This is probably because you must have installed it on an AppVM (in the non-persistent part of the system) or in a dispVM.

Borrowing from the whonix wiki a decent explanation on this:

Inheritance [1] Persistence [2]
TemplateVM n/a Everything
TemplateBasedVM /etc/skel/ to /home/ /rw/ (includes /home/ and bind-dirs)
DisposableVM Template /etc/skel/ to /home/ /rw/ (includes /home/, /usr/local and bind-dirs)
DisposableVM /rw/ (includes /home/, /usr/local and bind-dirs) Nothing

[1]: Upon creation
[2]: Following shutdown

Okay, Thank you,
I will try first for the solution,
then I will post in a new thread.

You’re welcome!

btw, I also found a similar table to the above on the Qubes documentation (It’s probably the original):