The dark theme (prefer-dark) does not work in fedora 39

Tried to enable the dark theme on fedora-39-gnome/minimal using gsettings/dconf, and it doesn’t seem to work in qubes. Has anyone run into this problem yet?

These are the ones I usually try:
xfconf-query -c xsettings -p /Net/ThemeName -s "Adwaita-dark"
and
gsettings set org.gnome.desktop.interface color-scheme "prefer-dark"

Yes, this is the same method I use. Unfortunately, it doesn’t work in fedora-39-gnome. I checked all the necessary gnome-settings-daemon packages, reinstalled xdg-desktop-portal, adwaita theme, libadwaita, and the dark mode toggle doesn’t work.

Do you have adwaita-qt5 installed in your TemplateVM? Does it help

Did you try to edit your template’s /etc/environment file to include:

QT_STYLE_OVERRIDE=adwaita-dark

In my f39 minimals, dark-theme works as usual, so probably it could be something with some gnome package interfering.

Adwaita-qt
QT_STYLE_OVERRIDE=adwaita-dark

Your suggestion is for QT based applications. I use qgnomeplatform for them without any problems.
In my case the dark gnome(libadwaita) theme is not working. I have checked the full template and the minimal template. I also upgraded fedora-38 to 39 and got the same effect with dark theme not working.