The Bluetooth device is disconnected

I am running QubesOS 4.2.1 with the latest kernel and have been experiencing Bluetooth connection issues. I recently reinstalled the system and after installing blueman and bluez to the template, I tried to connect my CSR8510 BT dongle to an untrusted domain using BluetoothAdapter and BluetoothManager. However, I receive the following error message:

Connection Failed : br-connection-profile-unavailable

I was previously able to connect and output sound from a soundbar by attaching the dongle, turning on Bluetooth with BluetoothAdapter, and searching for devices with BluetoothManager. Is there any other package that I need to install? I have been struggling with this issue for a day now and would appreciate any help.

What template did you use? If fedora then try debian.

1 Like

I am using Debian 12 with the Xfce desktop environment and am experiencing Bluetooth connection issues. I am able to connect to my Bluetooth device, but the connection is quickly lost. I am not sure if I need to install any additional packages or if there are any unnecessary packages causing the problem.

From what I’ve seen on the other forums, this looks like a pulseaudio problem. Have you tried their solutions?



Thank you so much for your help! After following your instructions and running the Ubuntu commands, I was able to successfully connect my Bluetooth device via the GUI. I can finally enjoy my music on my soundbar! I really appreciate your assistance.

systemctl --user enable pulseaudio
systemctl --user start pulseaudio

i tried this command and success.

For the use with pipewire the libspa-0.2-bluetooth package seems to be required: