Temporary qube, firefox history backs into template

Fresh install of Qubes 4.2 RC5, I start the temporary qube Firefox, the places I go to on internet appear in Template of Temporary. Information survives reboot.

Settings still says that the Template is offline.

I also cloned the Work Qube, found that the Terminal functions as online. Not sure if that was intended.

Qubes 4.2 RC5 did, Unlike RC4, installed cleanly to my Librem 13 V2, which I had installed Qubes 4.2 RC2, and fully updated. I tried the Qubes 4.2 RC3, and it dumped out into the console.


Are you sure you used a DispVM and not the template itself? When you start a new DispVM, it creates a new qube named dispX where “X” is a random number between 1 and 9999.

1 Like

I carefully looked again. and sure enough. you were correct. The template was online.

I reinstalled all of Qubes 4.2 RC5. I choose from the template column “default-dvm”
then Settings. top of Settings is (Dom0) Settings default-dvm,
Net Qube shows default (sys-firewall) (current)

Looks like the same Settings page for the version in the App column.

Template column for fedora38-xfce default (none) (current)
same for Vault.

I thought all the Templates were set to “not” to be connected to internet.???

or what did I do to turn it on in a fresh install?

1 Like

All templates should have their netvm set to “default (none)”. Disposable templates, however, need one. They should have the netvm you want to use for each disposable qube you will create.
I’m not familiar with the new Qubes 4.2 menu as I’ve never used it, but you may need to start applications from “default-dvm”.

The new menu has 3 tabs for: Apps, Templates, Services , you can’t go wrong if you don’t switch to templates or services (where all the network provider, sys-usb etc… are put)

1 Like

I am exactly describing what I am seeing. Right after I finish a the complete install

The Template for Default-DVM, Settings. I see it is attached to sys-firewall. I did not start it.

Either I have a bad download, or there is a hiccup in RC5. If some others have a computer that can be spared for a few hours to test what happens with a fresh install of Qubes 4.2RC5. That would seem like a way to prove me wrong (again. sigh)

I could try to download Qubes 4.2RC5 again. On beginning of install, the self test of the install should have stopped. I was not sitting here watching that real closely. For me to test more. I would have to drive somewhere else to download Qubes 4.2RC5 again. At a different location, on a computer that I had also done something to be more certain it was not corrupted. More hours.

If anyone else is testing Qubes 4.2RC5 download, they might look to see what is occurring for them,

This is configured as expected:

Network and firewall settings for disposable templates can be set as they can for a normal qube. By default a disposable will inherit the network and firewall settings of the disposable template on which it is based.

apparatus. Yours is a good educational comment.

I must have miss written.

The Template itself is started (on fresh install) attached to internet. I did not change the Template internet connection to on. I did turn it off. Immediately.

I am well aware of what the relationship should be Templates and its children Apps.

Can I hear from someone who has accomplished a fresh install of Qubes 4.2 RC5. AND have as a first thing to do, they look at the Template for disp-dvm? Perhaps, after have started their networking, ask the Template to see if it sees the internet. (Right. It should not see the internet)

I am left with: There is something wrong with my download of Qubes4.2RC5. How I installed Qubes4.2RC5 onto the flash drive. My hardware.

Which template are you talking about?
Default configuration example:
debian-12-xfce - TemplateVM type, Template property is unset/unavaivable, netvm set to (none)
default-dvm - AppVM type, Template property set to debian-12-xfce, netvm set to sys-firewall, “Disposable template” property is set
dispX - qube created from default-dvm, DispVM type, Template set to default-dvm, netvm set to sys-firewall (the same as its disposable template default-dvm)

Interesting. I went back and the disp-dvm, both the app, and the Template pointed to fedora 38 xfce.

Template for Debian / Settings is none (no internet connection)

Template for Fedora 38 / Settings is none (no internet connection)

Template for Whonix ?? / Settings is none (no internet connection)

Template for Whonix Gateway / Settings points to the other Whonix. Which of course is no danger, as long as the first is closed. But, Interesting.

disp-dvm for both the app and the Template look the same to me. When I started disp-dvm app (Firefox) it started with a number on the back. As opposed to the Template disp-dvm (firefox) started saying dvm, no number on the back.

This seems like a minor bug. Which is what Release Candidates are for discovering.

Thanks to the Qubes Developers for all their spot on work.

EDIT: 11-6-2023
I started T-480 and on boot up, the Template/disp-dvm/Settings showed the firewall is linked to.

I verified that Template/disp-dvm/Firefox did get online.
Yep. I turned the Settings to (none).

Then I discovered that App/disp-dvm/Settings was also showed “none” and Firefox also would not let me online.

Thinking the developers might have fixed this. I ran the Update for Fedora-38. Which wanted to restart several Qubes when it finished, Including sys-net and sys-firewall.

after the Qubes restarted, Template/disp-dvm/Settings was again showing to be linked to the sys-firewall. Guessing the connection is, maybe being turned on when the firewall restarts.

I finished all the updates. Restarting Firewall (with Qubes Manager)did not turn on the Template/disp-dvm.

I restarted computer. Template/disp-dvm/Settings showed (none) and Template/disp-dvm/Firefox would not get online.

App/disp-dvm/Firefox would not get online. App/disp-dvm/Settings said its internet connection was (none) Yes, the disp-dvm/Firefox was suffixed with a number.

I notice that the Settings for both the App, and the Template of disp-dvm have the same header across the top of the Settings box. I also notice that the term in the internet connections is now “none” different label in that box than my first install.

I can set the internet to Firewall in App/disp-dvm/Settings box. And the Template stays off. Someone fixed it. I had not updated immediately after installing. (I have no at home internet connection, so I act differently than I should)

Since I still see websites in Template/disp-dvm/Firefox. I will assume the worst, and reinstall Qubes again, but then I will go down to library download updates before doing anything else.


So you want the disposable template to have a different netvm from the disposable qube creted from this disposable template?
It’s not supported right now. You can open the issue about it on github so developers could consider adding this feature:

It is important to distinguish between a template and a disposable template. A lot of confusion in this thread seems to stem from conflating these.

Thanks to all of you illuminating this discussion with knowledge.

I wanted to hold off saying it, until I could prove it. and I did not prove it.

I suspect part of the issue is from Firefox Synchronizing between the browsers: One in the Template. One running in the disp-dvmxxxx. (xxxx is the number sequence assigned when the app version of disp-dvm starts)

That has implications beyond this discussion, if I open any Template to install third party software.

and, I don’t think anything that I do inside the App disp-dvm, which I do while running it should automatically install itself into the Template disp-dvm. Such that every time I now start the App ‘disp-dvmxxxx’ those changes are inside the app ‘disp-dvmxxx’

After installing Qubes4.2RC5 onto another computer and updating it. I see some changes have been made. I feel I should test closely the different ways this is set to work.