TB4 Dock for System76 Galago Pro (galp6)

I have a System76 Galago Pro (galp6 specs). I’ve install Qubes 4.1.1 without issues.

I want to use a dock to connect:

  • 2x displays (can be Display Port, HDMIs, or Thunberbolt?)
  • Audio 3.5mm combo (out and microphone in?)
  • Ethernet
  • Multiple fast USB connections

A few questions:

  1. Can I get away without daisy chaining for dual displays? I think I would prefer to just have Display Ports for video. Open to thoughts here.
  2. Should my system (Qubes 4.1 / System76 galp6) support all features of TB 4? Is this even necessary for my needs? It does seem TB 4 has many benefits.
  3. Should it be possible to use a microphone in via 3.5mm in Qubes OS? I know it can otherwise be done with a normal USB.
  4. Specific recommendations on docks are appreciated!

I don’t have experience with docks on qubes but for this requirement only I would imagine you’d need a joint sys-net-usb. You could either create one, or attach your usb controller to sys-net and prevent the existing sys-usb from starting on boot.

I wouldn’t use my sys-net/sys-usb-to-ethernet to connect storage devices to it.

You already have RJ45 gigabit port, why would you need additional one -on dock?

Only you know the answer.

I don’t see why it wouldn’t be possible?

I’m not sure what you mean. Can you please link something, or explain?

No experience too, but I’m sure someone else will jump in with this.

People usually treat this as an advantage actually, but If you have multiple ports, why not? You need to define your needs regarding using 2 displays - what do you want to see on them. I’m not sure though.

How were you able to install Qubes 4.1.1? I verified fully my .iso according to the extensive directions, checking and rechecking at every instruction. Did you install to the internal “Blue” solid state HD? I tried installing to an external and the Galp6 froze at installing “networking.” I tried with and without the wireless module connected so there would be no rf interference. It goes to dracut as often has happened to me in the past: 255.390305 and 255.390469 initque 472 not all disks found, regenerate your initramf. One of those dracut password/partitioning things? I can run Virtual Box on PopOS. I removed IME with coreboot-configurator but this should not effect anything. System76 support said the Qubes kernel might not be compatible with the hardware. Earlier Qubes kernel version might? Any ideas on how to make this work? Does the kind of hard drive matter, solid state versus moving part disk? Shouldn’t but maybe the cpu to HD path matters. Thanks!