Tab command is not working for auto-complete

There are times [often] when if I’m pressing tab [in terminal] for auto-complete I’m receiving this message and the terminal will not work anymore
“Install package ‘yp-tools’ to provide command ‘ypcat’? [N/y]/1”
Is it there something missconfigured or?

This is Qubes OS. Which terminal you are talking about? Is it dom0, or AppVM? If later, which OS? Did you try to reinstall the template?

I’m having that problem on all vms and in dom0 as well.
Not always … but usually if I’m using tab for auto-complete it will happen.
Not, didn’t try to reinstall the template. It is a fresh install [3,4 days ago] so I didn’t expect this is something that I need to do.

I installed on fedora [it is the only OS I’m using on all templates] some apps like code, vim, authtool, veracryt …

Tried to reproduce this on dom0 and I wasn’t able. So right now I’m not sure if I was able to reproduce this on dom0 ever before.
Tried to reproduce in diferrent vms and I was able [all based on fedora 32 … ]

Fedora 32 in templates is not supported anymore: Supported releases | Qubes OS.

That’s strange

NAME=Fedora
VERSION="32 (Thirty Two)"
ID=fedora
VERSION_ID=32
VERSION_CODENAME=""
PLATFORM_ID="platform:f32"
PRETTY_NAME="Fedora 32 (Thirty Two)"

I used Qubes OS 4.0.4 to install it but still I’m having fedora 32

Nothing strange here. Qubes OS 4.0.4 was released before the EOL of Fedora 32. You should upgrade your templates.

Updated to fedora 33. Same issue.
Something that I noticed is that this is happening, usually if not always, when running command scp then execute tab multiple times

Maybe your tab key is broken and works half the times?

:thinking:

Hmm. Didn’t thought at that.
Is it there a good way to test if this is the case?

Option A): Open a text editor. Press tab multiple times and see if it adds a “tab space” every time you click it.

Option B) If you’re willing to use the terminal, open a terminal in a qube and run xev. Then press the tab key and see if the terminal says you’ve pressed that key (or if it updates, at least).

Tested. All the time appears keycode 23.
I’m 99.99% sure the problem is not tab key.
If I’m using tab with any other command [e.g. ls, …] this will not happen.
The problem occurs ONLY when I’m using tab with scp

LE: Actually the problem is on other commands as well like sudo mount /dev/{tab} ... problem

Founded the problem but not sure how to fix it [to find exactly what couses this].
So … I installed ZSH on fedora-33 template so it is used by all VMs.
I also configured it… I started a VMs terminal and access the bash shell so scp or any other command will not break it using tab.

The problem is with ZSH or with it + my config.

How can I investigate to see what exactly is cousing this?

1 Like

So the problem was only my config. Used zpreto
I switch to oh my zsh at that problem disappeared
Still don’t know exactly what was the problem with my old config …