T480S 4.2 Lingering Issues

Running qubes 4.2 on a Thinkpad T480s, i5-8350. For the most part Qubes runs very well on this machine and all the hardware works but I’m dealing with two lingering issues I’m looking for support with and one I encountered this evening.

  1. When I close the lid/suspend and reopen it takes at least 30 seconds for the login screen to re-appear. Somestimes on longer suspends (like over night) it wont bring up the login at all and just black screen and I have to hard restart.

  2. This is a strange issue, it typically happens when I’m scrolling a webpage using the side scroll bar or when draggin a window frame around. The screen freaks out rapidly flashing the window in different locations until i let either the window pane or scroll bar go and then it goes back to normal.

  3. This is the fist time I encountered this one today as i havent brought the laptop to a different location since installing 4.2, basically I was connected to my wifi network everything working properly, shut the lid/suspend for transport (didnt turn off machine), when at the other location I opened back up and the wifi wouldnt work at all wouldnt let me find any connection. I had to hard restart to find connections at the new location.

Any input appreciated.

What’s your browser?
Does it happen with scrolling on every webpage or only on pages with heavy graphics?
Try to disable hardware acceleration in your browser.
Or increase VPCUs count for your qube.

Maybe related issue:

Try to blacklist the wireless drivers:

The reason it takes a long time to return from suspend is the initialization of the internal devices, many of them are USB. In the BIOS in the IO settings you can disable camera, microphone, sd card reader, etc. and you should get a much faster wake up from suspend, on my T480 it’s ~5 sec with only lan, wifi and usb active.

If your system is regularly crashing during suspend, you could have a hardware issue.

If you haven’t done it, try and generate xorg.conf it might help with your graphics issues.

sudo X :1 -configure
sudo cp /root/xorg.conf.new /etc/X11/xorg.conf

In xorg.conf you can see all the options for the intel driver, they are commented out as default. If you keep experiencing graphics issues, you can try and enable TearFree.

1 Like

I think i have the wifi issue resolved.

Here is a video clip of the issue I’m getting with the windows flashing (please note this isnt browser issue it happens with any windows i pull around or scroll on) it’s not limited to the firefox browser. It’s completely random but does seem to happen more if the mouse pointer is on the lower portion of the screen for some reason.

Do you have only Intel iGPU or second dGPU as well?
Did you try to use kernel-latest (currently kernel 6.6.2) in dom0?
Do you have some custom xorg configuration? Do you have some other files excpt for 00-keyboard.conf in /etc/X11/xorg.conf.d directory in dom0?

  1. just the Igpu no Dgpu
  2. Kernel 6.1.62 which was the kernal installed when doing a fresh install of 4.2
  3. I have made no custom configurations, it’s basically Qubes straight out of the box currently as i wanted to make sure everything was working well before changing anything
  4. nothing has been added to Dom0 since install

I’ve been able to succesfully replicate the issue 100% now by moving the mouse cursor to a particular point in the display. If a Qube window lets say Firefox (happens on any program window) is maximized on the screen and I move my cursor to far left edge of the display where the (arrow and line) cursor changes like if you wanted to resize a window and move it, to around the bottom inch of the display the window starts to FREAK out like I showed in the video. I can replicate this 100%, it’s not the only time it happens but it is what I’m able to replicate reliably. This leads me to belive it has something to do with window sizing as when the window is freaking out it’s overflowing onto the other side of the display. I messed around clicking on and off setting in the window manager to no avail and changing the resolution. Wierdly changing the “scale” to 1.5x made the issue go away but its not a fix as when it’s set to 1.5x anything of the far left of the screen is no longer clickable so changing it to 1.5x seems to break other stuff in the process.

Is there a way to turn off the ability to resize a window when it’s maximized? for example in MS Windows if you maxmize the program you cant resize it unless you minimize it back down to a smaller box first. I really do think it has something to do with the system freaking out because it thinks I want to resize a window but it’s already at full size. I know it’s not technically “fullscreen” in qubes so it thinks it’s still a resizeable window that can be dragged.

Lenovo ThinkPad T480 - #11 by aronowski user: [aronowski]

found this post topic where this user also has the same issue where it glitches if the cursor is on the bottom portion of the screen. So it would seems it’s not MY particular device only which at least makes me feel better that it’s not a bad hardware issue.

I can only suggest you to try the kernel-latest in dom0.

So I’ve been messing with it all day, I’ve been able to get a “fix” working but there’s definitely something weird going on how it is set standard. It has something to do with scaling or something attached to it. Like i said previously if I set the scaling to 1.5x the issue went away but i could use a portion of the left part of the screen. I set a custom value at 1.1x and the issue has gone away and I’m unable to replicate it now. I noticed when the issue was happening that there were two horizontal dashed green lines one at the top of the screen and one about a quarter inch above the task bar that would flash when it was freaking out. It lead me to believe it has something to do with screen size/settings. So far I havent found a downside to setting the custom scaling at 1.1x but will continue to monitor. But if the Qubes team see’s this it may be worth investigating any errors in default scaling code.

I’ll write a recap of our glitch-hunting conversation from another thread, which got split as requested, so it doesn’t deviate from the HCL one.

Sounds like the thing I had, but for me this seizure was happening, when the cursor was close to the bottom right corner instead. This glitch went away after changing RAM sticks, what I did just to upgrade the available memory.

I don’t know if that older RAM stick was faulty or just loose, that such a glitch was present, as well as sporadic problems, when the cursor started bouncing across the screen and moving on its own, which I at least could mitigate by turning off the touchpad as input device.

Since @Raist wrote about only adding another RAM stick to their machine, I suggested: what would happen if @Raist unplugged the stick that was always there, before the new one has been added? Maybe then the glitching would go away. May be worth a shot.

Furthermore, I suggested filing a bug report at qubes-issues. I understand, how hard this can be to replicate, especially since it went away for me after changing the RAM sticks, but sometimes life’s just like that. After all, I can be the guinea pig when it comes to working with sys-gui-gpu, as that does work for me. :stuck_out_tongue:

1 Like