System76 with Latest Qubes (Galp6 with 4.1.1)

I would like to install Qubes on System76 Galp6. I have verified .asc and the .iso should be good, although there are always further checks to perform. [For instance, Java verification of TAILS can be forged looks like to me]. One other forum member said he succeeded installing Qubes on same model but it didn’t work for me. I wanted to keep my internal HD and install to USB to HD SATA. In past installations of Qubes, sometimes the installer prefers the primary SATA. I don’t think it matters the type of HD, solid state or motor and moving parts. I have removed Intel ME but this also should not effect anything. VirtualBox works just fine on PopOS/ubuntu. Is there a particular kernel that works best with Galp6 hardware? Does anyone know how to proceed or in what direction I should start researching? Thanks!

I think it’s not installing because I was trying to install it to an external HD and I have to clone PopOS to another drive because I still want it before installing Qubes on the inner drive. Thanks. If there is more to the story, please let me know in the meantime.

installed Qubes did not recognize WIFI hardware

It is possible to install 4.1.1 on Galp6. The problem I was encountering was due to the type of target installation medium. Installing to the solid state internal drive worked quickly, while an external USB connected disk drive froze on installing “networking.” However, now that I have installed to the internal “Blue” drive after cloning the original PopOS to another disk, I find that Qubes did not recognize the wifi module although it did accept the ethernet connection. Does anyone know how to get the wifi up? Is there open firmware for the wifi module, for instance? Would a different release of Qubes be more likely to recognize the wifi card?

Got Wifi working. What you have to make sure is that you leave turned on wireless when you power down PopOS. I reinstalled with wireless on during last OS/firmware state and Qubes found wireless (there is also the option to add devices in the networking Qube which would probably work since Dom0 could find iwlwifi).

Increase Screen Brightness

One last question. Although I had brightness on at full in Pop, Qubes did not keep this value. How do I increase display brightness in Qubes?

Have you tried the display brightness keys on your keyboard? They often look like a sun or lightbulb with up and down arrows. They usually require the Fn key to be held down. I also have a System76 laptop, and I see the brightness meter going up and down onscreen when I press these buttons.

Yes, the brightness keys are unresponsive. I’ve looked into commands for XFCE4-power-manager which interfaces with the EC, I think, and that’s what could increase power to the backlight but I haven’t found an answer yet.

More problematic is the intermittent wifi recognition (see the HCL yaml on this model which I have posted).

See if you can use the latest from Index of /qubes/iso/
You have to install with UEFI to get the latest and greatest kernell for dom0 and Fedora. I don’t have a 76 to tell you…

Do you mean doing something along these lines:

R 4.1.2 still does not support Alder Lake wifi. The latest kernel is not selected automatically. What parameters should I select?

Hardware compatibility question - >
TAILS 5.10 supported the wifi but 5.11 does not. Neither Debian or Arch support the native wifi module. What is it about Alder Lake wifi?

The screen is also still at half illumination and there is no obvious way to change that.

There is only one method to run Whonix on S76G6 and that is with VirtualBox. Morphing Debian into Kicksecure and installing Whonix doesn’t work because Debian doesn’t bare metal recognize wifi and Gnome-Redhat Boxes virtualizing causes vm nesting errors with Whonix Installer. KVM Whonix doesn’t work because there is no RADS for Fedora (or Pop!/Ubuntu), at least it is not mentioned on the Whonix installation instructions site.

What about Alder Lake wifi is not amenable to tor-based OS?

Firmware: that’s what the issue was. Latest illumination and wifi work perfectly now. It took Fedora/Syzdell (probably) a few updates to provide firmware with the illumination increase via keyboard and wifi compatibility. Nice work!

Now the improvement of the illumination adjusted by keyboard has disappeared and there is no way to adjust screen resolution. Wifi still works. I wonder what causes these changes. If I boot Fedora and update a drive, then the firmware might also be changed with an update?