System76 Lemur Pro (lemp9)

Hello folks,

In my spare time I figured I would see if I could get Qubes running on a Lemur Pro that has just been sitting around. Or at least how far I can get, anyway. I don’t intend to annoy anyone here by asking you to fix it for me, I’m just documenting my journey here in case anyone cares to read or comment about it. There’s a high probably I haven’t figured obvious things out as I’ve never run Qubes before.

Anyway, Qubes 4.0.3 installs and runs just fine. The onboard Intel 9560 wireless adapter does not get detected, which is totally expected. So I proceed to connect a usb ethernet adapter and then get updates going. But first that means I need to point the firewall to sys-usb:

$ qvm-prefs --set sys-firewall netvm sys-usb
$ qvm-service --enable sys-usb network-manager  # then restart sys-usb 

I’m jumping straight to bleeding edge since this is new hardware:

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest kernel-qubes-vm

Sweet, after a reboot uname shows Linux 5.8. And the good news is that sys-net lspci now shows a wireless adapter’s name in the list. Running ip address doesn’t show the wireless network interface. I think that means udev doesn’t know about the new wireless interface. I’m guessing I’ll need to brush up on Fedora style sysconfig stuff to see how I can convince it to add the interface. So that’ll be my next step after a small break.

The only other defect I’ve noticed so far is that the system doesn’t hibernate when I close it, even after updating to kernel 5.8. I’ll see about tackling that if/when I get networking working.

Any luck with this, isuldor? I’ve installed on an oryx pro and, aside from the net-vm not detecting wifi, the gui is sluggish in general. I’m wondering if maybe the system76 drivers would need to be installed in order for qubes to run smoothly?

Hi heccamin,

Your oryp6 has a NVIDIA GeForce RTX 2000 series GPU. The Qubes docs says that “Proprietary (NVIDIA/AMD) drivers are known to be sometimes highly problematic, or completely unsupported.” They recommend using kernel-latest and building the module.

Good luck there.

As for wireless on my lemp9, now that I’m getting back to it, I’m not quite sure how to proceed yet. The issue is that the network interface does not appear in the list like my usb ethernet adapter did. Only a loopback:

[isuldor@dom0 ~]$ ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever

Neither is there a wireless interface in sys-net:

[user@sys-net ~]$ ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: vif5.0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 32
    link/ether fe:ff:ff:ff:ff:ff brd ff:ff:ff:ff:ff:ff
    inet scope global vif5.0
       valid_lft forever preferred_lft forever
    inet6 fe80::fcff:ffff:feff:ffff/64 scope link
       valid_lft forever preferred_lft forever

Before I had been thinking that I needed to look at udev, but I can see the wireless module is loading fine:

[isuldor@dom0 ~]$ lspci -k
00:14.3 Network controller: Intel Corporation Device 02f0
    Subsystem: Intel Corporation Device 0034
    Kernel driver in use: pciback
    Kernel modules: iwlwifi

[isuldor@dom0 ~]$ sudo dmesg | grep 00:14.3
[    1.126624] pci 0000:00:14.3: [8086:02f0] type 00 class 0x028000
[    1.126698] pci 0000:00:14.3: reg 0x10: [mem 0x9fa18000-0x9fa1bfff 64bit]
[    1.126962] pci 0000:00:14.3: PME# supported from D0 D3hot D3cold
[    2.646506] pciback 0000:00:14.3: xen_pciback: seizing device
[   17.563413] pciback 0000:00:14.3: xen_pciback: vpci: assign to virtual slot 0
[   17.563849] pciback 0000:00:14.3: registering for 2

I’ll have to keep thinking about it.

Based on what I see on this post, the issue is that, until recently, AX200 wifi was not supported by Qubes. This seems to have changed, and can be fixed using these instructions. I’m considering installing Qubes in my Lemur Pro and, if you are still working on this, would love to hear back if this works.

decided to give it a try myself. looks to work properly. i followed isuldor’s initial instructions to get a usb ethernet set up, then followed the instructions in the git issue, then ran the following commands:

$ qvm-service --disable sys-usb network-manager
$ qvm-prefs --set sys-firewall netvm sys-net
$ qvm-service --enable sys-net network-manager

this is my first time using qubes, so not even sure all the commands are necessary. i have not tested this extensively, but at least initial testing shows wireless networking now functional.


I’m currently running Pop on my lemp9, it is my main laptop so I need it to be stable, are there any other major issues? I would like to install Qubes soon if it works properly.


Got it installed, it is working well. Thanks for the above instructions, I was able to get my WiFi working properly following them!

No other major flaws/issues so far.

Wifi and the rest of the system seems mostly stable so far. I haven’t tried hibernation recently, but as OP noticed, it did fail for me at least once. I also have not tried updating the firmware as described on this System76 page.

attempted to upload “qubes-hcl-report -s” files here, but new users do not appear to have that ability