System unusable without nomodeset

I’ve tested the latest kernel version (Qubes-20221015-kernel-latest-x86_64.iso) but the system is still very slow overall with horizontal black lines when text/icons are loading (even typing) which render the system unusable.

I have an intel+nvidia laptop (rtx 3050), so naturally I tried nouveau.modeset=0 but it doesn’t resolve anything.

The only partial “solution” I’ve found is to add the nomodeset parameter. However, this is less than ideal (for starters, I’m unable to change screen brightness).

How can I resolve this issue? Should I disable the dgpu entirely, and if so how?

I should mention that Fedora 37 workstation (5.19.16-300.fc37.x86_64) works without issues out of the box.

1 Like

I tried installing the newest kernel-latest version (6.0.2-2) but the situation is still the same.

I suspect it might be due to Qubes using Xorg (I have no issues on Wayland).

Can anyone recommend what I should try next?

There’s a GitHub issue that describes graphics artifacts where the image is being redrawn. The problem there seems to be with the Intel GPU, but it may still be worth a try (run as root and reboot):

[user@dom0 ~]$ sudo -i
[root@dom0 ~]# cat << EOF > /etc/X11/xorg.conf.d/99-intel.conf
Section "OutputClass"
Identifier "intel"
MatchDriver "i915"
Driver "intel"
Option "AccelMethod" "sna"
Option "TearFree" "true"
Option "DRI" "3"
[root@dom0 ~]# exit
1 Like

Thanks! That solved it completely in dom0 but I can still see the lines in the cryptsetup password prompt

Update kernel to 6.07 and to Xen 4.14.5-12 especially because the latter resolved numerous issues with Xen.