System doesnt boot after creating a usb qube


Today i made a fresh install with qubes 4.1 and because i dont have a ps2 connecter i am forced to use a usb keyboard. So after i finished the install and updated everything i wanted to create the usb qube with this command:

sudo qubesctl state.sls qvm.usb-keyboard

everything worked? but when i rebooted and used my encryption password the system wouldnt boot. So i tried again with a fresh install and before executing the same command i tried to install the package that is listed in the docs:

sudo qubes-dom0-update qubes-mgmt-salt-dom0-virtual-machines

But this only gave me the error curl 37 and that it couldnt open the file and that the package is already installed. So i checked the version that is installed with the latest one in github and just tried:

sudo qubesctl state.sls qvm.usb-keyboard

again. But after rebooting and decrypting it just hang itself up. In the picture is the output (i censored some stuff bc i dont know what i should and shouldnt share)

i made an uefi install does this play a role?

pc spec? how many drive you use for this system ?
are you using external drive ?


A ryzen 2700x and a GTX1080. Because i only have one pc i have a dual install with windows and fedora on the internal disks and Qubes on an external. But everytime i load qubes i deactivate the sata ports in the bios

I’ve seen many errors caused by installing qubes into external drive, from the log you provide the main problem is not sys-usb thing.

Could you let the sata ports activated and see what happen?
and if it’s still like that.

Maybe this could be one that causing the problem, could you run qubes installer medium and boot into rescue qubes os, after wait for some time, press 3 to skip to shell and run lsblk, efibootmgr -v

1 Like

thanks i will try

well somehow the system doesnt want to boot from the external drive anymore bc of that i also cant get an output

no idea whats broken. Well i guess i will just go with an internal drive then…

There’s a different booting with internal or external (removable) drive in uefi,
normally that qubes efi file are located in / boot/efi/EFI/qubes/

when you do installation the efi file are installed in that folder, to boot from removable device in uefi, simply copy all of them to /boot/efi/EFI/boot/
and create an uefi entry pointing to this boot file.