Sys-Whonix/Sys-net or sys-usb causes system to crash/reboot loop

Hey, i will apology for any stupid question.

I already had the problem when installing Qubes that when I installed templates - on main installation(as genreal OS) - the first installation step went through, but the installer aborted at “setup networking” and restarted, which led to a corrupt installation every time.

i then tried the step again, with a fresh usb stick, but the problem did not go away. i then installed qubes without templates, which i did after the installation was successful.

now i installed whonix yesterday and configured my system further. when i wanted to reboot, i had a similar problem. from the point where sys-whonix is started, my pc falls into a “reboot loop”. if i start whonix while the system is running, there is no problem.

Here are some logs from sys-whonix (qrexec.sys-whonix.log):

2024-04-14 04:49:36.708 qrexec-daemon[93294]: qrexec-daemon.c:1549:main: qrexec-agent has disconnected /etc/qubes-rpc/qubes.WaitForSession: /var/run/qubes/qrexec.47 not found, domain might be dead 2024-04-14 04:49:37.086 qrexec-client[144525]: qrexec-client.c:250:wait_for_session_maybe: wait-for-session exited with status 256 2024-04-14 04:49:37.086 qrexec-client[144525]: exec.c:461:execute_qrexec_service: qubes_connect: Connection refused 2024-04-14 04:49:37.091 qrexec-client[144525]: qrexec-client.c:640:main: Failed to open data vchan connection domain dead 2024-04-14 04:49:46.401 qrexec-daemon[93294]: qrexec-daemon.c:1426:handle_agent_restart: cannot connect to qrexec agent: No such file or directory 2024-04-14 04:49:46.401 qrexec-daemon[93294]: qrexec-daemon.c:1551:main: Failed to reconnect to qrexec-agent, terminating 

I’ve checked journalctl but nothing “suspicious” there. Are there any other logfiles, which could be helpful?

EDIT: I deleted sys-whonix and dependencies and still the same problem, so I guess it must be any of sys-net or sys-usb…

Log guest-sys-net-dm.log:

Log guest-sys-firewall.log

To be honest, i dont understand the times regarding journalctl --list-boots since the dates are kinda weird.

Try to disable sys-usb autostart and check if autostarted sys-net will cause a reboot.
Try to disable sys-net autostart and check if autostarted sys-usb will cause a reboot.
Try to remove the PCI devices one by one from the qube that is causing reboot to determine which PCI device could cause this issue.


thanks for your answer.

i currently have 4 devices assigned to the qube and as far as i can see, device 70:00.4 is the problem. this is my usb hub/switch which has mouse and keyboard connected, which has 2 channels so i can switch depending on whether i’m using the pc or the notebook