Sys-whonix keeps crashing?

I cant figure this out. I can start sys-whonix up by itself but as scoon as i try to do updates (which use whonix) or start up any appvm that is using sys-whonix the sys-whonix. When I try I get the error:

Qube sys-whonix has failed to start: Cannont connect to qrexec agent for 60 seconds, see /var/log/xen/console/guest-sys-whonix-log for details

Then the next message is

sys-whonix has shutdown

So I didnt understand the log but have posted it here Debian Pastezone

Thoughts? (please!)

Am @'ing Adrenelos just in case he has time? @adrelanos

Perhaps sys-whonix itself cannot be started. If you just start up sys-whonix and wait for 5 minutes, you’ll probably get the same result.

When sys-whonix is started, are you able to open a terminal?

Actually it seems the sys-whonix appvm can be started but as soon as i try to run something, it crashes

no. I tried from the qubes manager, from the menu, and from the dom0 console no matter which way i try it crashes (also tried opening different terminals, crash…

Could you try disabling memory balancing in the qube memory settings?

From the logs you provided, I see that you’re running sys-whonix with a max memory of 1024MB is that right? Can you try bumping the memory temporarily to 2048 max and 800 for initial?

Tried that, and I was able to open xterm but it was very slow to open and pretty much froze.

So i bumped it up to 800/2000 with and without mem balancing. Strangely with mem balancing disabled I wasnt able to pull up an xterm? but when I reduced the memory again, and had mem balancing disabled an xterm popped up - though it took a long time and pretty much froze once it started

There’s currently some memory issue since a qrexec update from a few weeks ago. All my qubes were unable to connect to qrexec just like you at that time. I was able to fix that by changing the initial memory from 400 to 500 minimum. Currently my sys-whonix qube is running with 500/4000 and it’s working fine, so try changing the memory a little bit around mine and see when you can get a stable system.

Did you make any change to sys-whonix? If I run a terminal in it, it only has 390 MB of used memory and tor is working fine.

No changes, it just went with the defaults (then changed the mem as i didnt think it would take over a gig?)

Well I did both (increased mem and turned off load balancing) and restarted it a few times and its working now.
2gig is quite a bit for a sys-vm i would think, hopefully that will get ironed out soon.

Thanks to you both!

1 Like

In Qubes OS 4.2 there will be whonix 17 available, maybe memory requirements will be reduced (it’s unlikely with computer software though but :woman_shrugging: )